# CVE-2026-100653: vLLM 0.22.1 before 0.28.0 Incomplete Artifact Pin Propagation

> vLLM fails to propagate model revision pins for specific architectures, allowing upstream changes to alter behavior in pinned deployments.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 1 Oct 2026
- **Also known as:** GHSA-hhv2-872h-628q, GHSA-r3cf-2wgr-7xh9, MINI-mv84-q9fg-9xv8, MINI-rgg5-f64q-xh58, PYSEC-2026-4324

## What is CVE-2026-100653?

CVE-2026-100653 is a high-severity vulnerability in Vllm Vllm, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models. In versions from 0.22.1 through 0.28.0, the operator-supplied model revision pin (--revision / --code-revision) is not propagated to several Hugging Face artifact loads for the FunAudioChat and Tarsier2 architectures: the WhisperFeatureExtractor and speech_tokenizer PreTrainedTokenizerFast loads in vllm/model_executor/models/funaudiochat.py and the Qwen2VLConfig.from_pretrained call used by Tarsier2ProcessingInfo in vllm/model_executor/models/qwen2_vl.py. As a result, deployments pinned to a reviewed revision still resolve these behavior-affecting processor, tokenizer, and config artifacts from the repository's default revision, so a later change to the upstream default branch can alter audio preprocessing, speech tokenizer behavior, or Tarsier2 configuration without any change to the operator's configured pin. This is a supply-chain integrity and reproducibility failure for pinned deployments; it is residual to the earlier fix tracked as GHSA-3ww4-5jv9-j5gm / CVE-2026-47155 and does not constitute remote code execution or a trust_remote_code=False bypass. The issue is fixed in version 0.28.0.

Weakness: CWE-348 (Use of Less Trusted Source)

## Which versions are affected by CVE-2026-100653?

1 open source package ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.22.1 | 0.28.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-100653?

Upgrade vllm to 0.28.0 or later.

## Is CVE-2026-100653 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100653 exists.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100653 and fix it if it is affected.

What it is: CVE-2026-100653 is a high-severity vulnerability in Vllm Vllm, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100653 exists.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.22.1; fixed in 0.28.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100653/ (Markdown: https://insights.sbomify.com/CVE-2026-100653/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100653
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100653
- OSV: https://osv.dev/vulnerability/CVE-2026-100653

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100653/
Summaries are generated and may contain mistakes; the official description above is the record.
