CVE-2026-100660 Netty before 4.2.18.Final QpackEncoder Unbounded Memory Retention

High 8.7 Published Updated

Remote attackers can cause server memory exhaustion and denial of service by exploiting unbounded QPACK encoder state retention in Netty's HTTP/3 codec.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-100660?

CVE-2026-100660 is a high-severity denial of service vulnerability in netty, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Netty's HTTP/3 codec (io.netty:netty-codec-http3) from 4.2.0.Final through 4.2.17.Final retains unbounded per-stream QPACK encoder state. QpackEncoder stores a queue and a dynamic-table index tracker for every encoded field section that references the QPACK dynamic table, keyed by the peer-controlled QUIC stream ID, and these entries are released only when the remote decoder sends a Section Acknowledgment or Stream Cancellation instruction — not when the HTTP/3 stream completes. There is no limit on the number of tracked streams, field sections, or retained bytes. A remote, unauthenticated HTTP/3 client can advertise a non-zero QPACK dynamic-table capacity, acknowledge the table insertion so the server reuses a dynamically indexed response header, and then omit all mandatory Section Acknowledgments while issuing sequential requests over a single QUIC connection, bypassing concurrent-stream limits and causing unbounded heap growth until the server exhausts memory (denial of service). Fixed in 4.2.18.Final.

Weakness: CWE-770

Which versions are affected by CVE-2026-100660?

How do I fix CVE-2026-100660?

No fix has been published for CVE-2026-100660 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-100660 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100660 exists.

Sources

Also known as GHSA-495p-pchh-r4mc, GHSA-8rpm-pm7h-f5fv, UBUNTU-CVE-2026-100660.

Is CVE-2026-100660 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free