# CVE-2026-100661: Netty HTTP/3 QPACK Prefixed Integer DoS via Unbounded Accumulation

> Remote attackers can cause denial of service in Netty HTTP/3 by sending crafted QPACK data, leading to unbounded memory growth and CPU starvation.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Sep 2026
- **Updated:** 2 Oct 2026
- **Also known as:** GHSA-7m86-g9j9-26xf, GHSA-v5p2-hmgx-3xrx, UBUNTU-CVE-2026-100661

## What is CVE-2026-100661?

CVE-2026-100661 is a high-severity denial of service vulnerability in netty, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty's HTTP/3 codec (io.netty:netty-codec-http3) versions 4.2.0.Final through 4.2.17.Final contain a denial-of-service vulnerability in the QPACK prefixed-integer decoder (QpackUtil.decodePrefixedInteger), which does not bound the number of continuation bytes it will process. A remote, unauthenticated peer can open a QPACK unidirectional stream (type 0x02 encoder or 0x03 decoder) and send a first byte with all prefix bits set (e.g. 0xFF for a 7-bit prefix or 0x3F for a 5-bit prefix) followed by an endless run of 0x80 continuation bytes. The decoder returns -1 ('need more bytes'), so callers never consume the input, the ByteToMessageDecoder cumulator grows without bound, and each decode() invocation re-scans the whole accumulated buffer, yielding O(N^2) CPU cost. The result is unbounded per-connection heap growth (OutOfMemoryError) and event-loop CPU starvation, reachable in every configuration. Fixed in 4.2.18.Final.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-100661?


## How do I fix CVE-2026-100661?

No fix has been published for CVE-2026-100661 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-100661 being exploited?

There is no known exploitation of CVE-2026-100661 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100661 and fix it if it is affected.

What it is: CVE-2026-100661 is a high-severity denial of service vulnerability in netty, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100661 in the wild and no public exploit code.

Affected product: netty. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100661/ (Markdown: https://insights.sbomify.com/CVE-2026-100661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100661
- OSV: https://osv.dev/vulnerability/CVE-2026-100661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100661/
Summaries are generated and may contain mistakes; the official description above is the record.
