CVE-2026-100669 Grav before 2.0.25 Sensitive File Disclosure via Case-Variation Bypass

High 8.7 Published Updated

Unauthenticated attackers can bypass case-sensitive IIS deny rules to read sensitive configuration files and secrets in Grav CMS deployments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-100669?

CVE-2026-100669 is a high-severity vulnerability in getgrav grav, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Grav before 2.0.25 ships web server configuration samples whose access-control deny rules are matched case-sensitively. In webserver-configs/web.config (IIS), every deny rule (user_sensitive_folders, user_accounts, user_data, user_error_redirect, user_pages, system, vendor, ignore_folders) sets ignoreCase="false" on its URL Rewrite <match> element, overriding the IIS default of ignoreCase="true"; because these are rewrite matches rather than <requestFiltering> elements, there is no case-insensitive fallback. On IIS running over case-insensitive NTFS, an unauthenticated remote attacker can vary the case of a folder name or file extension (for example GET /user/CONFIG/system.YAML) so that no deny rule matches and the IIS static file handler resolves and returns the underlying file, disclosing sensitive data such as configuration secrets or account password hashes. Whether a bypassed file is actually returned depends on MIME registration: .json is served by default, while .yaml/.yml return HTTP 404.3 on a stock IIS unless a YAML MIME mapping has been added. The same class of gap exists in the bundled webserver-configs/lighttpd.conf, whose user/(config|env), directory, script-extension, root-file and dotfile rules lack the (?i) modifier, though it is lower risk because lighttpd typically runs on case-sensitive filesystems. Deployments served by Apache (.htaccess), nginx, Caddy, or the PHP built-in server are not affected. The issue is fixed in 2.0.25; because the .htaccess installer heal does not touch web.config or lighttpd.conf, operators must re-copy the corrected sample files after upgrading.

Weakness: CWE-178

Which versions are affected by CVE-2026-100669?

How do I fix CVE-2026-100669?

No fix has been published for CVE-2026-100669 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-100669 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100669 exists.

Sources

Also known as GHSA-cxcx-pfx3-w4vx, GHSA-pg8v-xw58-frq8.

Is CVE-2026-100669 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free