# CVE-2026-100670: Grav CMS 2.0.14 through 2.0.24 Privilege Escalation via Blueprint Guard Bypass

> Authenticated backend operators can escalate to super-admin by bypassing blueprint guards via dot-notation keys, gaining full control.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-mwjj-r7vm-pgqm, GHSA-xw59-q7ph-pgh5

## What is CVE-2026-100670?

CVE-2026-100670 is a high-severity vulnerability in getgrav grav, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grav CMS 2.0.14 through 2.0.24 contains a privilege escalation vulnerability in the group and account blueprints. The access map is gated by a `security@: admin.super` guard that is resolved by the field's exact path, so a submitted flat dot-notation key such as `access.admin.super` (instead of the nested `access[admin][super]`) matches no blueprint rule, survives BlueprintSchema::filterArray() and flattening, and is written by FlexObject::update() via setNestedProperty(), which splits on `.` and reconstructs the nested value. An authenticated backend operator using the flex accounts backend who holds admin.users but not admin.super can therefore grant admin.super to their own account or to a group they belong to and escalate to full super-admin, gaining control over configuration, plugin and theme installation, the file manager, and all accounts. Fixed in 2.0.25, which drops any dotted key whose ancestor path is disabled or marked validate.ignore.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-100670?


## How do I fix CVE-2026-100670?

No fix has been published for CVE-2026-100670 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-100670 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100670 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100670 and fix it if it is affected.

What it is: CVE-2026-100670 is a high-severity vulnerability in getgrav grav, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100670 exists.

Affected product: getgrav grav. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100670/ (Markdown: https://insights.sbomify.com/CVE-2026-100670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100670
- OSV: https://osv.dev/vulnerability/CVE-2026-100670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100670/
Summaries are generated and may contain mistakes; the official description above is the record.
