# CVE-2026-100699: Nodemailer before 10.0.9 Malformed Envelope Recipient via RFC 5322 Comment

> Attackers can inject malformed recipient addresses via RFC 5322 comments, potentially causing unintended email delivery or data modification.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** CLEANSTART-2026-AA77700, CLEANSTART-2026-TR78672, DEBIAN-CVE-2026-100699, ECHO-1bcb-fe8f-0e9b, GHSA-fcjc-3m4q-q926, GHSA-g57g-f23g-4646, MINI-84jf-6p6q-mfgc, MINI-cgj3-vp82-6w5r, MINI-rfp5-f4mx-rf26, UBUNTU-CVE-2026-100699

## What is CVE-2026-100699?

CVE-2026-100699 is a medium-severity vulnerability in nodemailer, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nodemailer is a Node.js email-sending library. In versions >= 9.1.0 and < 10.0.9, the address parser (src/addressparser) mishandles addresses whose local-part is a quoted string and that are followed by RFC 5322 comments, allowing trailing comment-separated domain atoms to be retained in the normalized address. For example, the input "user"@example.com(x)evil.com is parsed to the address value 'user@example.com evil.com', which contains additional attacker-controlled domain text separated by a literal space. This parsed value is used without further strict recipient validation when the message envelope is built (envelope.to in src/mime-node), so a malformed/ambiguous recipient address can be accepted and placed in the SMTP envelope. Whether this results in delivery to an unintended recipient on real SMTP servers has not been confirmed. The issue is a variant of the RFC 5322 comment parsing problem addressed in GHSA-cc9r-2j5m-2m83, affecting the separate quoted-local-part code path. Version 10.0.9 contains a fix.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-100699?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | From 9.1.0 | 10.0.9 |
| `nodemailer` | npm | From 9.1.0 | 10.0.9 |

## How do I fix CVE-2026-100699?

Upgrade nodemailer to 10.0.9 or later.

## Is CVE-2026-100699 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100699 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100699 and fix it if it is affected.

What it is: CVE-2026-100699 is a medium-severity vulnerability in nodemailer, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100699 exists.

Affected packages and fixed versions:
- nodemailer (npm): affected from 9.1.0; fixed in 10.0.9
- nodemailer (npm): affected from 9.1.0; fixed in 10.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100699/ (Markdown: https://insights.sbomify.com/CVE-2026-100699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100699
- OSV: https://osv.dev/vulnerability/CVE-2026-100699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100699/
Summaries are generated and may contain mistakes; the official description above is the record.
