{"answers":{"affected":"2 open source packages ship an affected version, including nodemailer.","exploited":"There is no known exploitation of CVE-2026-100702 in the wild and no public exploit code.","fix":"Upgrade nodemailer to 10.0.2 or later.","what":"CVE-2026-100702 is a high-severity denial of service vulnerability in nodemailer, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-100702 and fix it if it is affected.\n\nWhat it is: CVE-2026-100702 is a high-severity denial of service vulnerability in nodemailer, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-100702 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nodemailer (npm): affected all versions; fixed in 10.0.2\n- nodemailer (npm): affected all versions; fixed in 10.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-100702/ (Markdown: https://insights.sbomify.com/CVE-2026-100702/index.md)","id":"CVE-2026-100702","markdown":"https://insights.sbomify.com/CVE-2026-100702/index.md","name":"CVE-2026-100702","record":{"aliases":["CLEANSTART-2026-EE74509","CLEANSTART-2026-VD48874","CLSA-2026-1790718876","CLSA-2026-1790803367","CLSA-2026-1790876521","DEBIAN-CVE-2026-100702","ECHO-aee1-014d-2428","GHSA-5hcf-56h7-4fvx","GHSA-8vvx-rff5-p5rq","MINI-37hh-j3cg-7fw6","MINI-4j96-p69v-5vvh","MINI-55wq-84p3-6vv4","MINI-5vh6-chm4-mj3w","MINI-6p28-mxj6-mq83","MINI-7265-8wwj-h42w","MINI-79ww-9955-6335","MINI-8m7w-43mh-c8vx","MINI-g6rw-rh74-69h7","MINI-gfrf-jwx6-2qwr","MINI-hg66-775r-qpwf","MINI-r7cv-qqrp-34mx","MINI-vm87-2524-g6pp","MINI-w4gw-mjxc-4gx7","MINI-w844-9f5j-3g68","UBUNTU-CVE-2026-100702"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js email library","requires_auth":"none","summary":"Attackers can crash the Node.js process by sending deeply nested recipient arrays, causing stack exhaustion in the Nodemailer library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"Nodemailer before 10.0.2 fails to properly flatten deeply nested arrays in recipient fields such as to, cc, and bcc, allowing attackers to cause stack exhaustion. Attackers can supply a deeply nested JSON recipient array that triggers recursive Array.toString() conversion, exhausting the call stack and terminating the Node.js process.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Nodemailer before 10.0.2 Stack Exhaustion via Nested Recipient Arrays","id":"CVE-2026-100702","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Kyverno before 1.19.1 Cross-Namespace Data Access via globalcontext.Lib","id":"CVE-2026-100703"},"packages":[{"ecosystem":"npm","fixed":["10.0.2"],"introduced":["0"],"last_affected":[],"package":"nodemailer","purl":null,"source":"GHSA-8vvx-rff5-p5rq"},{"ecosystem":"npm","fixed":["10.0.2"],"introduced":["0"],"last_affected":[],"package":"nodemailer","purl":"pkg:npm/nodemailer","source":"GHSA-8vvx-rff5-p5rq"}],"prev":{"headline":"Nodemailer 5.0.0 through 10.0.1 TLS servername Cache Confusion","id":"CVE-2026-100701"},"products":["nodemailer"],"published":"2026-09-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-26","vendors":["nodemailer"]},"summary":"Attackers can crash the Node.js process by sending deeply nested recipient arrays, causing stack exhaustion in the Nodemailer library.","url":"https://insights.sbomify.com/CVE-2026-100702/"}