# CVE-2026-100702: Nodemailer before 10.0.2 Stack Exhaustion via Nested Recipient Arrays

> Attackers can crash the Node.js process by sending deeply nested recipient arrays, causing stack exhaustion in the Nodemailer library.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 26 Sep 2026
- **Also known as:** CLEANSTART-2026-EE74509, CLEANSTART-2026-VD48874, CLSA-2026-1790718876, CLSA-2026-1790803367, CLSA-2026-1790876521, DEBIAN-CVE-2026-100702, ECHO-aee1-014d-2428, GHSA-5hcf-56h7-4fvx, GHSA-8vvx-rff5-p5rq, MINI-37hh-j3cg-7fw6, MINI-4j96-p69v-5vvh, MINI-55wq-84p3-6vv4, MINI-5vh6-chm4-mj3w, MINI-6p28-mxj6-mq83, MINI-7265-8wwj-h42w, MINI-79ww-9955-6335, MINI-8m7w-43mh-c8vx, MINI-g6rw-rh74-69h7, MINI-gfrf-jwx6-2qwr, MINI-hg66-775r-qpwf, MINI-r7cv-qqrp-34mx, MINI-vm87-2524-g6pp, MINI-w4gw-mjxc-4gx7, MINI-w844-9f5j-3g68, UBUNTU-CVE-2026-100702

## What is CVE-2026-100702?

CVE-2026-100702 is a high-severity denial of service vulnerability in nodemailer, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nodemailer before 10.0.2 fails to properly flatten deeply nested arrays in recipient fields such as to, cc, and bcc, allowing attackers to cause stack exhaustion. Attackers can supply a deeply nested JSON recipient array that triggers recursive Array.toString() conversion, exhausting the call stack and terminating the Node.js process.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-100702?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | All versions | 10.0.2 |
| `nodemailer` | npm | All versions | 10.0.2 |

## How do I fix CVE-2026-100702?

Upgrade nodemailer to 10.0.2 or later.

## Is CVE-2026-100702 being exploited?

There is no known exploitation of CVE-2026-100702 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100702 and fix it if it is affected.

What it is: CVE-2026-100702 is a high-severity denial of service vulnerability in nodemailer, published on 26 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100702 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodemailer (npm): affected all versions; fixed in 10.0.2
- nodemailer (npm): affected all versions; fixed in 10.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100702/ (Markdown: https://insights.sbomify.com/CVE-2026-100702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100702
- OSV: https://osv.dev/vulnerability/CVE-2026-100702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100702/
Summaries are generated and may contain mistakes; the official description above is the record.
