# CVE-2026-100703: Kyverno before 1.19.1 Cross-Namespace Data Access via globalcontext.Lib

> Tenants can access cluster-scoped cached data from other namespaces via the globalcontext library, bypassing RBAC restrictions.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** BIT-kyverno-2026-100703, GHSA-59v6-2x73-wfg4, GHSA-cmr3-jwxg-m6m3, MINI-76q7-cch4-wfpp, MINI-c953-mmv6-rgwq, MINI-hr4c-83gw-ggc8, MINI-jf2r-wvxj-jxp4, MINI-p6h6-7mm6-vwqc, MINI-r7q5-m56r-rm9g

## What is CVE-2026-100703?

CVE-2026-100703 is a high-severity vulnerability in kyverno, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kyverno 1.16.0 through 1.19.0 registers the globalcontext.Lib CEL library in its policy environment without confining it to the policy's namespace, unlike the sibling libraries (resource.Lib, http.Lib, configMap loader) which are handed the policy namespace. A tenant who can create a namespaced policy (e.g. NamespacedValidatingPolicy, and likewise the namespaced mutating, deleting, generating, and image-validating policy kinds) in their own namespace can call globalContext.get("<entry>", "") and receive the full cached contents of a cluster-scoped GlobalContextEntry, including data cached from namespaces the tenant has no RBAC permission to read. No admission validation rejects such calls. Fixed in 1.19.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-100703?

1 open source package ship an affected version, including kyverno.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kyverno` | Bitnami | From 1.16.0 | 1.19.1 |

## How do I fix CVE-2026-100703?

Upgrade kyverno to 1.19.1 or later.

## Is CVE-2026-100703 being exploited?

There is no known exploitation of CVE-2026-100703 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100703 and fix it if it is affected.

What it is: CVE-2026-100703 is a high-severity vulnerability in kyverno, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100703 in the wild and no public exploit code.

Affected packages and fixed versions:
- kyverno (Bitnami): affected from 1.16.0; fixed in 1.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100703/ (Markdown: https://insights.sbomify.com/CVE-2026-100703/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100703
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100703
- OSV: https://osv.dev/vulnerability/CVE-2026-100703

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100703/
Summaries are generated and may contain mistakes; the official description above is the record.
