CVE-2026-100705 Kyverno before 1.19.1 SSRF via legacy apiCall service executor
Attackers can exploit SSRF in Kyverno's legacy API executor to access cloud metadata and internal services, bypassing egress controls.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-100705?
CVE-2026-100705 is a high-severity server-side request forgery vulnerability in kyverno, published on 26 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Kyverno before 1.19.1 is vulnerable to server-side request forgery. The default egress blocklist (169.254.169.254, 169.254.169.253, metadata.google.internal, 127.0.0.0/8, ::1/128) and the scoped-token control were wired only into the new CEL http.Get/Post library and were never applied to the legacy apiCall service executor (pkg/engine/apicall/executor.go) or to the GlobalContextEntry external-API path, which handle every non-CEL context[].apiCall.service call. Because these paths use a plain net/http client with no egress filtering and no validation of the configured service URL, a ClusterPolicy or GlobalContextEntry author — or, where a deployed policy templates the service URL from the admission resource, a lower-privileged resource submitter — can cause Kyverno to issue GET/POST requests to an arbitrary host, including the cloud metadata endpoint, loopback, and any in-cluster service, reading cloud instance credentials and reaching internal endpoints with Kyverno's network position. The executor also unconditionally attaches Kyverno's projected ServiceAccount token to the attacker-chosen destination; the token is audience-scoped, limiting its replay value. Fixed in 1.19.1.
Weakness: CWE-918
Which versions are affected by CVE-2026-100705?
1 open source package ship an affected version, including kyverno.
| Package | Affected | Fixed in |
|---|---|---|
kyverno Bitnami | All versions | 1.19.1 |
How do I fix CVE-2026-100705?
Upgrade kyverno to 1.19.1 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-100705 being exploited?
There is no known exploitation of CVE-2026-100705 in the wild and no public exploit code.
Sources
Also known as BIT-kyverno-2026-100705, GHSA-8x9j-8h3w-5cxq, GHSA-q825-p383-r9v5, MINI-3r9p-75wf-5qrw, MINI-4ppp-fc7f-x4vc, MINI-83rm-v4hm-m3rw and 10 more.