{"answers":{"affected":"1 open source package ship an affected version, including kyverno.","exploited":"There is no known exploitation of CVE-2026-100705 in the wild and no public exploit code.","fix":"Upgrade kyverno to 1.19.1 or later.","what":"CVE-2026-100705 is a high-severity server-side request forgery vulnerability in kyverno, published on 26 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-100705 and fix it if it is affected.\n\nWhat it is: CVE-2026-100705 is a high-severity server-side request forgery vulnerability in kyverno, published on 26 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-100705 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- kyverno (Bitnami): affected all versions; fixed in 1.19.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-100705/ (Markdown: https://insights.sbomify.com/CVE-2026-100705/index.md)","id":"CVE-2026-100705","markdown":"https://insights.sbomify.com/CVE-2026-100705/index.md","name":"CVE-2026-100705","record":{"aliases":["BIT-kyverno-2026-100705","GHSA-8x9j-8h3w-5cxq","GHSA-q825-p383-r9v5","MINI-3r9p-75wf-5qrw","MINI-4ppp-fc7f-x4vc","MINI-83rm-v4hm-m3rw","MINI-87j7-whfg-q863","MINI-9h3w-v9p6-mcp4","MINI-f892-vqxc-f2jm","MINI-g7w6-4rg7-x5f8","MINI-h6cp-735j-7x2x","MINI-hqvr-6g6v-9546","MINI-ppv5-8h9v-64q8","MINI-r5qx-2pfh-xq93","MINI-vj9c-9454-hrq6","MINI-x9w5-wmr8-f59v"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Kubernetes policy engine","requires_auth":"high_privilege","summary":"Attackers can exploit SSRF in Kyverno's legacy API executor to access cloud metadata and internal services, bypassing egress controls.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Kyverno before 1.19.1 is vulnerable to server-side request forgery. The default egress blocklist (169.254.169.254, 169.254.169.253, metadata.google.internal, 127.0.0.0/8, ::1/128) and the scoped-token control were wired only into the new CEL http.Get/Post library and were never applied to the legacy apiCall service executor (pkg/engine/apicall/executor.go) or to the GlobalContextEntry external-API path, which handle every non-CEL context[].apiCall.service call. Because these paths use a plain net/http client with no egress filtering and no validation of the configured service URL, a ClusterPolicy or GlobalContextEntry author — or, where a deployed policy templates the service URL from the admission resource, a lower-privileged resource submitter — can cause Kyverno to issue GET/POST requests to an arbitrary host, including the cloud metadata endpoint, loopback, and any in-cluster service, reading cloud instance credentials and reaching internal endpoints with Kyverno's network position. The executor also unconditionally attaches Kyverno's projected ServiceAccount token to the attacker-chosen destination; the token is audience-scoped, limiting its replay value. Fixed in 1.19.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kyverno before 1.19.1 SSRF via legacy apiCall service executor","id":"CVE-2026-100705","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"kyverno before 1.19.1 Privilege Escalation via Policy apiCall urlPath","id":"CVE-2026-100706"},"packages":[{"ecosystem":"Bitnami","fixed":["1.19.1"],"introduced":["0"],"last_affected":[],"package":"kyverno","purl":"pkg:bitnami/kyverno","source":"BIT-kyverno-2026-100705"}],"prev":{"headline":"Kyverno before 1.19.1 ImageValidatingPolicy Exception Bypass","id":"CVE-2026-100704"},"products":["kyverno"],"published":"2026-09-26","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-26","vendors":["kyverno"]},"summary":"Attackers can exploit SSRF in Kyverno's legacy API executor to access cloud metadata and internal services, bypassing egress controls.","url":"https://insights.sbomify.com/CVE-2026-100705/"}