# CVE-2026-100706: kyverno before 1.19.1 Privilege Escalation via Policy apiCall urlPath

> Attackers can escalate privileges to cluster admin by bypassing namespace restrictions via URL-encoded path traversal in policy API calls.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 26 Sep 2026
- **Also known as:** BIT-kyverno-2026-100706, GHSA-5qq8-67g6-4h2w, GHSA-j68q-wq49-88gg, MINI-2fvw-whc2-rhwf, MINI-32c2-qpwf-r7gj, MINI-3xvc-wcm4-x4h6, MINI-4w44-h73m-v6rg, MINI-7jr7-gv76-7wh9, MINI-9fqp-pghp-fxcw, MINI-m649-f32p-w88m, MINI-mq38-wr77-g6rm, MINI-pc4f-93r6-7694, MINI-r94v-gv96-g594, MINI-wgp8-2pwr-2fcr, MINI-x772-h5v5-vfqq, MINI-xh96-wvw8-vjvq

## What is CVE-2026-100706?

CVE-2026-100706 is a critical vulnerability in kyverno, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

kyverno before 1.19.1 fails to properly validate URL-encoded path segments in Policy apiCall urlPath, allowing namespace tenants to bypass the per-namespace clamp and create objects in other namespaces as the admission-controller ServiceAccount. Attackers can exploit this by using percent-encoded directory traversal sequences to create MutatingWebhookConfiguration objects cluster-wide or PolicyException objects in the kyverno namespace, enabling privilege escalation to cluster admin.

Weakness: CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2026-100706?

1 open source package ship an affected version, including kyverno.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kyverno` | Bitnami | All versions | 1.19.1 |

## How do I fix CVE-2026-100706?

Upgrade kyverno to 1.19.1 or later.

## Is CVE-2026-100706 being exploited?

There is no known exploitation of CVE-2026-100706 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100706 and fix it if it is affected.

What it is: CVE-2026-100706 is a critical vulnerability in kyverno, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100706 in the wild and no public exploit code.

Affected packages and fixed versions:
- kyverno (Bitnami): affected all versions; fixed in 1.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100706/ (Markdown: https://insights.sbomify.com/CVE-2026-100706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100706
- OSV: https://osv.dev/vulnerability/CVE-2026-100706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100706/
Summaries are generated and may contain mistakes; the official description above is the record.
