# CVE-2026-100707: Kyverno before 1.19.1 Namespace Isolation Bypass via Percent-Encoded Path

> Low-privilege tenants can bypass namespace isolation via percent-encoded paths to read cross-namespace resources using Kyverno's service account.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** BIT-kyverno-2026-100707, GHSA-66wc-m66q-pf76, GHSA-c5qq-7g2q-cpqp, MINI-2x67-frr5-6657, MINI-39mw-xcpf-9wh9, MINI-84vm-hjwj-2v45, MINI-8fvg-hcpg-f3pj, MINI-95rg-hh79-hc5v, MINI-98f2-cgjc-pc5r, MINI-c2v4-gr2m-3xg2, MINI-c92j-q2ch-j7fw, MINI-f395-f2j8-gf2q, MINI-h4qw-9f3r-r2qr, MINI-hmv5-39gf-rjwc, MINI-p3hv-pq96-fmxf, MINI-vxcf-h783-9wcq

## What is CVE-2026-100707?

CVE-2026-100707 is a high-severity path traversal vulnerability in kyverno, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Kyverno before 1.19.1 contains a namespace isolation bypass in the apiCall context entry of namespaced Policy resources due to inconsistent path interpretation between validation and execution. A low-privilege tenant can use percent-encoded dot-segments in urlPath to bypass namespace checks and read resources from other namespaces using the Kyverno admission controller's ServiceAccount credentials.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-100707?

1 open source package ship an affected version, including kyverno.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kyverno` | Bitnami | All versions | 1.19.1 |

## How do I fix CVE-2026-100707?

Upgrade kyverno to 1.19.1 or later.

## Is CVE-2026-100707 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100707 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100707 and fix it if it is affected.

What it is: CVE-2026-100707 is a high-severity path traversal vulnerability in kyverno, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100707 exists.

Affected packages and fixed versions:
- kyverno (Bitnami): affected all versions; fixed in 1.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100707/ (Markdown: https://insights.sbomify.com/CVE-2026-100707/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100707
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100707
- OSV: https://osv.dev/vulnerability/CVE-2026-100707

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100707/
Summaries are generated and may contain mistakes; the official description above is the record.
