# CVE-2026-100709: Froxlor before 2.3.11 2FA Bypass via Namespace Confusion

> Attackers with a customer account and known admin password can bypass admin 2FA via ID collision, gaining administrator access.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Sep 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-9fq7-9w8p-c3qh, GHSA-pj38-8h4x-w384

## What is CVE-2026-100709?

CVE-2026-100709 is a high-severity authentication bypass vulnerability in froxlor, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor through 2.3.10 stores only a numeric user ID in remembered-2FA tokens (panel_2fa_tokens) without recording the account namespace, and the remembered-token lookup during login is not constrained to the customer or administrator account type. Because customer and administrator IDs are allocated from separate namespaces, a remembered-2FA token legitimately issued to a customer with a given ID also matches an administrator with the same ID. An attacker who controls a customer account with a colliding ID, holds a valid remembered-2FA cookie for it, and already knows the target administrator's password can bypass the administrator's TOTP second factor and obtain an authenticated administrator session. This is a second-factor bypass only; it does not defeat password authentication. Fixed in 2.3.11.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-100709?


## How do I fix CVE-2026-100709?

No fix has been published for CVE-2026-100709 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-100709 being exploited?

There is no known exploitation of CVE-2026-100709 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100709 and fix it if it is affected.

What it is: CVE-2026-100709 is a high-severity authentication bypass vulnerability in froxlor, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100709 in the wild and no public exploit code.

Affected product: froxlor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100709/ (Markdown: https://insights.sbomify.com/CVE-2026-100709/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100709
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100709
- OSV: https://osv.dev/vulnerability/CVE-2026-100709

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100709/
Summaries are generated and may contain mistakes; the official description above is the record.
