{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-100714 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-100714 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-100714 is a critical command injection vulnerability in froxlor, published on 26 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-100714 and fix it if it is affected.\n\nWhat it is: CVE-2026-100714 is a critical command injection vulnerability in froxlor, published on 26 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-100714 in the wild and no public exploit code.\n\nAffected product: froxlor. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-100714/ (Markdown: https://insights.sbomify.com/CVE-2026-100714/index.md)","id":"CVE-2026-100714","markdown":"https://insights.sbomify.com/CVE-2026-100714/index.md","name":"CVE-2026-100714","record":{"aliases":["GHSA-3w4g-cmpj-rj42","GHSA-fh3h-q9pj-x5qp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Froxlor hosting panel","requires_auth":"high_privilege","summary":"Administrators or attackers with settings access can inject commands into the Let's Encrypt cron job, achieving root code execution.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":9.4,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H","version":"4.0"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"Froxlor before 2.3.12 does not restrict or escape the system.letsencryptchallengepath setting: unlike sibling settings hardened in GHSA-33mp, the field has no string_regexp or required_otp guard, and its value is concatenated unescaped into the acme.sh command line built in lib/Froxlor/Cron/Http/LetsEncrypt/AcmeSh.php and executed by the root cron via FileDir::safe_exec. Because safe_exec only blacklists shell metacharacters such as ; | \u0026 \u003e \u003c \\ $ ~ ?, spaces and quotes survive and the value is word-split into additional acme.sh arguments. An administrator, or any actor able to write settings (for example through the settings-import API), can therefore inject acme.sh options such as --renew-hook, --pre-hook or --post-hook to obtain arbitrary command execution as root at the next Let's Encrypt cron run, or use --config-home/--cert-home for arbitrary file writes. Versions up to and including 2.3.10 are affected; the issue is fixed in 2.3.12.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Froxlor before 2.3.12 Command Injection via letsencryptchallengepath","id":"CVE-2026-100714","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Froxlor before 2.3.12 Arbitrary File Deletion via Symlink","id":"CVE-2026-100715"},"packages":[],"prev":{"headline":"Froxlor before 2.3.12 Privilege Escalation via SSH Key Sync","id":"CVE-2026-100713"},"products":["froxlor"],"published":"2026-09-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-26","vendors":["froxlor"]},"summary":"Administrators or attackers with settings access can inject commands into the Let's Encrypt cron job, achieving root code execution.","url":"https://insights.sbomify.com/CVE-2026-100714/"}