# CVE-2026-100714: Froxlor before 2.3.12 Command Injection via letsencryptchallengepath

> Administrators or attackers with settings access can inject commands into the Let's Encrypt cron job, achieving root code execution.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Sep 2026
- **Updated:** 26 Sep 2026
- **Also known as:** GHSA-3w4g-cmpj-rj42, GHSA-fh3h-q9pj-x5qp

## What is CVE-2026-100714?

CVE-2026-100714 is a critical command injection vulnerability in froxlor, published on 26 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Froxlor before 2.3.12 does not restrict or escape the system.letsencryptchallengepath setting: unlike sibling settings hardened in GHSA-33mp, the field has no string_regexp or required_otp guard, and its value is concatenated unescaped into the acme.sh command line built in lib/Froxlor/Cron/Http/LetsEncrypt/AcmeSh.php and executed by the root cron via FileDir::safe_exec. Because safe_exec only blacklists shell metacharacters such as ; | & > < \ $ ~ ?, spaces and quotes survive and the value is word-split into additional acme.sh arguments. An administrator, or any actor able to write settings (for example through the settings-import API), can therefore inject acme.sh options such as --renew-hook, --pre-hook or --post-hook to obtain arbitrary command execution as root at the next Let's Encrypt cron run, or use --config-home/--cert-home for arbitrary file writes. Versions up to and including 2.3.10 are affected; the issue is fixed in 2.3.12.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2026-100714?


## How do I fix CVE-2026-100714?

No fix has been published for CVE-2026-100714 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-100714 being exploited?

There is no known exploitation of CVE-2026-100714 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100714 and fix it if it is affected.

What it is: CVE-2026-100714 is a critical command injection vulnerability in froxlor, published on 26 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100714 in the wild and no public exploit code.

Affected product: froxlor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100714/ (Markdown: https://insights.sbomify.com/CVE-2026-100714/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100714
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100714
- OSV: https://osv.dev/vulnerability/CVE-2026-100714

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100714/
Summaries are generated and may contain mistakes; the official description above is the record.
