# CVE-2026-100717: froxlor before 2.3.12 CRLF Injection via validateUrl userinfo

> Authenticated users can inject CRLF characters into subdomain URLs to modify web server configurations, potentially leading to code execution or data exposure.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-gxx3-hwjc-h2gp, GHSA-qjpj-j6j4-mcpf

## What is CVE-2026-100717?

CVE-2026-100717 is a high-severity vulnerability in froxlor, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

froxlor is a server administration panel. In versions 2.3.10 and earlier, Validate::validateUrl rejects carriage return and line feed characters only in the path, query and fragment components returned by parse_url, and never inspects the userinfo (user:pass@) components. This is an incomplete fix for GHSA-c3p2. An authenticated low-privilege customer with subdomain-create rights (no admin or change_serversettings privilege required) can supply a subdomain redirect URL that carries a CR/LF payload in the userinfo portion (e.g. http://user%0areturn 200 "pwned";%0a@evil.com/). The value passes validation, survives IDNA encoding, and is written verbatim into the generated nginx or Apache vhost configuration, allowing the attacker to break out of the emitted directive and inject arbitrary web-server configuration lines. froxlor regenerates and reloads the web-server configuration as root, so the injected directives take effect server-wide and can hijack responses or read local files. The issue is fixed in version 2.3.12.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-100717?


## How do I fix CVE-2026-100717?

No fix has been published for CVE-2026-100717 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-100717 being exploited?

There is no known exploitation of CVE-2026-100717 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100717 and fix it if it is affected.

What it is: CVE-2026-100717 is a high-severity vulnerability in froxlor, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100717 in the wild and no public exploit code.

Affected product: froxlor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100717/ (Markdown: https://insights.sbomify.com/CVE-2026-100717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100717
- OSV: https://osv.dev/vulnerability/CVE-2026-100717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100717/
Summaries are generated and may contain mistakes; the official description above is the record.
