# CVE-2026-100718: Froxlor before 2.3.12 Authentication Bypass via EmailSender.add

> Authenticated customers can bypass external sender restrictions via API to register arbitrary sender addresses, enabling sender spoofing.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 26 Sep 2026
- **Updated:** 26 Sep 2026
- **Also known as:** GHSA-m5mc-84wm-h4mw, GHSA-m9j6-9856-68xf

## What is CVE-2026-100718?

CVE-2026-100718 is a high-severity authentication bypass vulnerability in froxlor, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Froxlor through 2.3.10 does not enforce the mail.allow_external_domains policy in the EmailSender.add API command. When an administrator has enabled the allowed-sender feature but disabled external allowed-sender domains (mail.enable_allow_sender = 1, mail.allow_external_domains = 0), an authenticated customer with API access can still use EmailSender.add to register an arbitrary external sender address for their mailbox, which is stored despite the policy. This creates a bypass between the UI/administrator configuration and the API, and — where the generated mail configuration consumes the allowed-sender table — allows a customer to authorize sender identities outside their hosted domains, facilitating sender spoofing. Fixed in 2.3.12.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2026-100718?


## How do I fix CVE-2026-100718?

No fix has been published for CVE-2026-100718 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-100718 being exploited?

There is no known exploitation of CVE-2026-100718 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100718 and fix it if it is affected.

What it is: CVE-2026-100718 is a high-severity authentication bypass vulnerability in froxlor, published on 26 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100718 in the wild and no public exploit code.

Affected product: froxlor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100718/ (Markdown: https://insights.sbomify.com/CVE-2026-100718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100718
- OSV: https://osv.dev/vulnerability/CVE-2026-100718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100718/
Summaries are generated and may contain mistakes; the official description above is the record.
