# CVE-2026-100722: vm2 before 3.12.2 Host Process Termination via Construct Trap

> An attacker can crash the host process by triggering an unhandled promise rejection via the construct trap in the vm2 sandbox.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** CLEANSTART-2026-QS01923, ECHO-7042-16e3-9cca, GHSA-2v2p-6j97-cjg9, MINI-jxmr-7jr9-jj3g, ROOT-APP-NPM-CVE-2026-100722

## What is CVE-2026-100722?

CVE-2026-100722 is a high-severity denial of service vulnerability in patriksimek vm2, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 before 3.12.2 does not apply host-side Promise rejection handling in the sandbox-to-host construct trap. In BaseHandler, the apply trap calls markHostPromiseHandled() on the returned value, but the adjacent construct path returns the result of Reflect.construct without the same sanitization. If an embedder exposes a constructable host function whose constructor returns a native rejected Promise, an untrusted script executed via VM.run can invoke it with `new` and ignore the result; the rejected host Promise crosses the bridge unhandled and, under Node's strict unhandled-rejection policy, is promoted to an uncaught exception that terminates the host process.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2026-100722?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.12.2 |
| `vm2` | npm | All versions | 3.12.2 |

## How do I fix CVE-2026-100722?

Upgrade vm2 to 3.12.2 or later.

## Is CVE-2026-100722 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100722 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100722 and fix it if it is affected.

What it is: CVE-2026-100722 is a high-severity denial of service vulnerability in patriksimek vm2, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100722 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.12.2
- vm2 (npm): affected all versions; fixed in 3.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100722/ (Markdown: https://insights.sbomify.com/CVE-2026-100722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100722
- OSV: https://osv.dev/vulnerability/CVE-2026-100722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100722/
Summaries are generated and may contain mistakes; the official description above is the record.
