# CVE-2026-100723: vm2 before 3.12.2 Memory Disclosure via zlib Buffer Pool

> Untrusted code in vm2 can read and modify host memory via zlib buffers if the zlib module is explicitly allowed in the sandbox configuration.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 1 Oct 2026
- **Also known as:** ECHO-bd4e-a735-8188, GHSA-489w-w794-jq94, MINI-3m46-pr38-c95q

## What is CVE-2026-100723?

CVE-2026-100723 is a medium-severity vulnerability in patriksimek vm2, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 before 3.12.2 does not apply its Buffer backing-store ownership invariant (byteOffset === 0 and buffer.byteLength === length) to Buffers returned from host builtin modules. When an application explicitly exposes Node's zlib module through NodeVM's builtin allowlist (require: { builtin: ['zlib'] }), zlib.deflateSync can return a Buffer backed by Node's shared small-buffer pool whose .buffer is the entire pool. Untrusted guest code can construct a full-width view of that ArrayBuffer (Buffer.from(result.buffer, 0, result.buffer.byteLength)) to read and modify bytes belonging to unrelated host buffers, disclosing and corrupting host-realm memory across the sandbox boundary.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-100723?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.12.2 |
| `vm2` | npm | All versions | 3.12.2 |

## How do I fix CVE-2026-100723?

Upgrade vm2 to 3.12.2 or later.

## Is CVE-2026-100723 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100723 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100723 and fix it if it is affected.

What it is: CVE-2026-100723 is a medium-severity vulnerability in patriksimek vm2, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100723 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.12.2
- vm2 (npm): affected all versions; fixed in 3.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100723/ (Markdown: https://insights.sbomify.com/CVE-2026-100723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100723
- OSV: https://osv.dev/vulnerability/CVE-2026-100723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100723/
Summaries are generated and may contain mistakes; the official description above is the record.
