# CVE-2026-100834: http4k before 6.48.0.0 Digest Authentication Replay Protection Bypass

> Attackers can bypass Digest authentication replay protection in http4k by reusing captured credentials due to a default configuration flaw.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Sep 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-c7jm-38gq-h67h, GHSA-r39r-ww5m-7mv9

## What is CVE-2026-100834?

CVE-2026-100834 is a high-severity vulnerability in http4k, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

http4k's Digest authentication module (org.http4k:http4k-security-digest) before versions 6.48.0.0, 5.42.0.0 and 4.51.0.0 defaults the nonceVerifier parameter of ServerFilters.DigestAuth and DigestAuthProvider to { true }, so every nonce is accepted regardless of its value, age, or prior use. Applications relying on this default have no replay protection on Digest authentication: an attacker who can capture a valid 'Authorization: Digest' response (for example by observing network traffic or reading logs) can replay it indefinitely against the same protected resource.

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2026-100834?

6 open source packages ship an affected version, including org.http4k:http4k-security-digest.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.http4k:http4k-security-digest` | Maven | All versions | 4.51.0.0 |
| `org.http4k:http4k-security-digest` | Maven | All versions | 4.51.0.0 |
| `org.http4k:http4k-security-digest` | Maven | From 5.0.0.0 | 5.42.0.0 |
| `org.http4k:http4k-security-digest` | Maven | From 5.0.0.0 | 5.42.0.0 |
| `org.http4k:http4k-security-digest` | Maven | From 6.0.0.0 | 6.48.0.0 |
| `org.http4k:http4k-security-digest` | Maven | From 6.0.0.0 | 6.48.0.0 |

## How do I fix CVE-2026-100834?

Upgrade org.http4k:http4k-security-digest to a fixed version for your release line: 4.51.0.0, 5.42.0.0 or 6.48.0.0.

## Is CVE-2026-100834 being exploited?

There is no known exploitation of CVE-2026-100834 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100834 and fix it if it is affected.

What it is: CVE-2026-100834 is a high-severity vulnerability in http4k, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-100834 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.http4k:http4k-security-digest (Maven): affected all versions; fixed in 4.51.0.0
- org.http4k:http4k-security-digest (Maven): affected all versions; fixed in 4.51.0.0
- org.http4k:http4k-security-digest (Maven): affected from 5.0.0.0; fixed in 5.42.0.0
- org.http4k:http4k-security-digest (Maven): affected from 5.0.0.0; fixed in 5.42.0.0
- org.http4k:http4k-security-digest (Maven): affected from 6.0.0.0; fixed in 6.48.0.0
- org.http4k:http4k-security-digest (Maven): affected from 6.0.0.0; fixed in 6.48.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100834/ (Markdown: https://insights.sbomify.com/CVE-2026-100834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100834
- OSV: https://osv.dev/vulnerability/CVE-2026-100834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100834/
Summaries are generated and may contain mistakes; the official description above is the record.
