# CVE-2026-100836: Edgeless Systems Contrast through 1.20.0 Denial of Service via ciphertextContainer

> Authenticated attackers can trigger a runtime panic in the transit-engine endpoint by submitting malformed ciphertext, causing service disruption.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-3ccm-4qq2-5wrp, GHSA-x66w-59x9-vvcf, GO-2026-5864

## What is CVE-2026-100836?

CVE-2026-100836 is a medium-severity denial of service vulnerability in edgelesssys contrast, published on 27 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Contrast through 1.20.0 contains a panic vulnerability in the transit-engine endpoint's ciphertextContainer.UnmarshalJSON function that fails to validate decoded ciphertext length before slicing. An authenticated workload with a valid mesh certificate can trigger a runtime panic by submitting a short base64-encoded ciphertext, causing log spam and request failures without crashing the process.

Weakness: CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-100836?

3 open source packages ship an affected version, including github.com/edgelesssys/contrast.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/edgelesssys/contrast` | Go | All versions | 1.21.0 |
| `github.com/edgelesssys/contrast` | Go | All versions | 1.21.0 |
| `github.com/edgelesssys/contrast` | Go | All versions | 1.21.0 |

## How do I fix CVE-2026-100836?

Upgrade github.com/edgelesssys/contrast to 1.21.0 or later.

## Is CVE-2026-100836 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100836 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100836 and fix it if it is affected.

What it is: CVE-2026-100836 is a medium-severity denial of service vulnerability in edgelesssys contrast, published on 27 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100836 exists.

Affected packages and fixed versions:
- github.com/edgelesssys/contrast (Go): affected all versions; fixed in 1.21.0
- github.com/edgelesssys/contrast (Go): affected all versions; fixed in 1.21.0
- github.com/edgelesssys/contrast (Go): affected all versions; fixed in 1.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100836/ (Markdown: https://insights.sbomify.com/CVE-2026-100836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100836
- OSV: https://osv.dev/vulnerability/CVE-2026-100836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100836/
Summaries are generated and may contain mistakes; the official description above is the record.
