{"answers":{"affected":"1 open source package ship an affected version, including monai. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100840 exists.","fix":"Upgrade monai to 1.6.1rc0 or later.","what":"CVE-2026-100840 is a high-severity code injection vulnerability in Project-MONAI MONAI, published on 27 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-100840 and fix it if it is affected.\n\nWhat it is: CVE-2026-100840 is a high-severity code injection vulnerability in Project-MONAI MONAI, published on 27 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100840 exists.\n\nAffected packages and fixed versions:\n- monai (PyPI): affected all versions; fixed in 1.6.1rc0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-100840/ (Markdown: https://insights.sbomify.com/CVE-2026-100840/index.md)","id":"CVE-2026-100840","markdown":"https://insights.sbomify.com/CVE-2026-100840/index.md","name":"CVE-2026-100840","record":{"aliases":["GHSA-873f-pvrv-4x83","GHSA-8jxj-xq3g-hvm2","PYSEC-2026-4015"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"MONAI Python library","requires_auth":"none","summary":"Attackers can execute arbitrary code by publishing malicious MONAI bundles that exploit unsafe configuration evaluation, requiring users to upgrade the library.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"monai","vendor":"project-monai"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-95","name":"Improper Neutralization of Directives in Dynamically Evaluated Code"}],"description":"MONAI through 1.6.0 contains a remote code execution vulnerability in the bundle configuration engine that resolves _target_ values to arbitrary importable callables without an allow list and passes $ expressions to Python eval(). Attackers can publish a malicious bundle with crafted configuration containing arbitrary code that executes when a victim loads the bundle using monai.bundle.load() or monai.bundle.run().","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"MONAI through 1.6.0 Remote Code Execution via bundle configuration","id":"CVE-2026-100840","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"MONAI through 1.6.0 PersistentDataset Remote Code Execution via Pickle Cache","id":"CVE-2026-100841"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.1rc0"],"introduced":["0"],"last_affected":[],"package":"monai","purl":"pkg:pypi/monai","source":"PYSEC-2026-4015"}],"prev":{"headline":"Contrast before 1.18.0 AML Injection Remote Code Execution","id":"CVE-2026-100839"},"products":["MONAI"],"published":"2026-09-27","related":[{"cvss_score":8.8,"headline":"MONAI before 1.5.2 Remote Code Execution via Pickle Deserialization","id":"CVE-2026-100846","kev_date_added":null,"published":"2026-09-27"},{"cvss_score":8.6,"headline":"MONAI before 1.6.0 OS Command Injection via dataset_name_or_id","id":"CVE-2026-100844","kev_date_added":null,"published":"2026-09-27"},{"cvss_score":8.5,"headline":"MONAI through 1.6.0 PersistentDataset Remote Code Execution via Pickle Cache","id":"CVE-2026-100841","kev_date_added":null,"published":"2026-09-27"},{"cvss_score":8.5,"headline":"MONAI before 1.6.0 Remote Code Execution via algo_from_pickle","id":"CVE-2026-100843","kev_date_added":null,"published":"2026-09-27"},{"cvss_score":8.5,"headline":"MONAI before 1.6.0 Remote Code Execution via NumpyReader","id":"CVE-2026-100845","kev_date_added":null,"published":"2026-09-27"},{"cvss_score":7.3,"headline":"MONAI through 1.6.0 _get_fake_spatial_shape eval() Sandbox Bypass via Attribute Chains","id":"CVE-2026-100842","kev_date_added":null,"published":"2026-09-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-28","vendors":["Project-MONAI"]},"summary":"Attackers can execute arbitrary code by publishing malicious MONAI bundles that exploit unsafe configuration evaluation, requiring users to upgrade the library.","url":"https://insights.sbomify.com/CVE-2026-100840/"}