# CVE-2026-100840: MONAI through 1.6.0 Remote Code Execution via bundle configuration

> Attackers can execute arbitrary code by publishing malicious MONAI bundles that exploit unsafe configuration evaluation, requiring users to upgrade the library.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-873f-pvrv-4x83, GHSA-8jxj-xq3g-hvm2, PYSEC-2026-4015

## What is CVE-2026-100840?

CVE-2026-100840 is a high-severity code injection vulnerability in Project-MONAI MONAI, published on 27 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

MONAI through 1.6.0 contains a remote code execution vulnerability in the bundle configuration engine that resolves _target_ values to arbitrary importable callables without an allow list and passes $ expressions to Python eval(). Attackers can publish a malicious bundle with crafted configuration containing arbitrary code that executes when a victim loads the bundle using monai.bundle.load() or monai.bundle.run().

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2026-100840?

1 open source package ship an affected version, including monai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `monai` | PyPI | All versions | 1.6.1rc0 |

Products: Project-Monai Monai.

## How do I fix CVE-2026-100840?

Upgrade monai to 1.6.1rc0 or later.

## Is CVE-2026-100840 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100840 exists.

## Other vulnerabilities in Project-MONAI MONAI

- [CVE-2026-100846](https://insights.sbomify.com/CVE-2026-100846/): MONAI before 1.5.2 Remote Code Execution via Pickle Deserialization (high 8.8)
- [CVE-2026-100844](https://insights.sbomify.com/CVE-2026-100844/): MONAI before 1.6.0 OS Command Injection via dataset_name_or_id (high 8.6)
- [CVE-2026-100841](https://insights.sbomify.com/CVE-2026-100841/): MONAI through 1.6.0 PersistentDataset Remote Code Execution via Pickle Cache (high 8.5)
- [CVE-2026-100843](https://insights.sbomify.com/CVE-2026-100843/): MONAI before 1.6.0 Remote Code Execution via algo_from_pickle (high 8.5)
- [CVE-2026-100845](https://insights.sbomify.com/CVE-2026-100845/): MONAI before 1.6.0 Remote Code Execution via NumpyReader (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100840 and fix it if it is affected.

What it is: CVE-2026-100840 is a high-severity code injection vulnerability in Project-MONAI MONAI, published on 27 Sep 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100840 exists.

Affected packages and fixed versions:
- monai (PyPI): affected all versions; fixed in 1.6.1rc0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100840/ (Markdown: https://insights.sbomify.com/CVE-2026-100840/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100840
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100840
- OSV: https://osv.dev/vulnerability/CVE-2026-100840

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100840/
Summaries are generated and may contain mistakes; the official description above is the record.
