# CVE-2026-100844: MONAI before 1.6.0 OS Command Injection via dataset_name_or_id

> Attackers can execute arbitrary OS commands by crafting a malicious YAML configuration file processed by the MONAI nnUNetV2Runner component.

- **Severity:** High 8.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-rghg-q7wp-9767, GHSA-x7wh-49x3-6748, PYSEC-2026-4019

## What is CVE-2026-100844?

CVE-2026-100844 is a high-severity command injection vulnerability in Project-MONAI MONAI, published on 27 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

MONAI before 1.6.0 is vulnerable to OS command injection in the nnUNetV2Runner component (monai.apps.nnunet.nnunetv2_runner). User-controlled values taken from the YAML configuration file (notably dataset_name_or_id) and from CLI/kwargs arguments are concatenated into a command string without quoting or validation and then passed to subprocess with shell=True, so shell metacharacters (e.g., ';' on Linux, '&' on Windows) are interpreted. If a victim loads and processes a crafted configuration file — for example by instantiating nnUNetV2Runner with the malicious YAML and invoking a training/validation job such as train_single_model() — arbitrary commands are executed with the privileges of the user running the job.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-100844?

3 open source packages ship an affected version, including monai and MONAI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `monai` | PyPI | All versions | 1.6.0 |
| `monai` | PyPI | All versions | 1.6.0 |
| `MONAI` | PyPI | All versions | 1.6.0 |

Products: Project-Monai Monai.

## How do I fix CVE-2026-100844?

Upgrade monai to 1.6.0 or later.

## Is CVE-2026-100844 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100844 exists.

## Other vulnerabilities in Project-MONAI MONAI

- [CVE-2026-100846](https://insights.sbomify.com/CVE-2026-100846/): MONAI before 1.5.2 Remote Code Execution via Pickle Deserialization (high 8.8)
- [CVE-2026-100840](https://insights.sbomify.com/CVE-2026-100840/): MONAI through 1.6.0 Remote Code Execution via bundle configuration (high 8.5)
- [CVE-2026-100841](https://insights.sbomify.com/CVE-2026-100841/): MONAI through 1.6.0 PersistentDataset Remote Code Execution via Pickle Cache (high 8.5)
- [CVE-2026-100843](https://insights.sbomify.com/CVE-2026-100843/): MONAI before 1.6.0 Remote Code Execution via algo_from_pickle (high 8.5)
- [CVE-2026-100845](https://insights.sbomify.com/CVE-2026-100845/): MONAI before 1.6.0 Remote Code Execution via NumpyReader (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100844 and fix it if it is affected.

What it is: CVE-2026-100844 is a high-severity command injection vulnerability in Project-MONAI MONAI, published on 27 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100844 exists.

Affected packages and fixed versions:
- monai (PyPI): affected all versions; fixed in 1.6.0
- monai (PyPI): affected all versions; fixed in 1.6.0
- MONAI (PyPI): affected all versions; fixed in 1.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100844/ (Markdown: https://insights.sbomify.com/CVE-2026-100844/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100844
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100844
- OSV: https://osv.dev/vulnerability/CVE-2026-100844

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100844/
Summaries are generated and may contain mistakes; the official description above is the record.
