# CVE-2026-100857: AzuraCast before 0.23.4 Remote Code Execution via Liquidsoap string interpolation

> Authenticated users can inject Liquidsoap code to execute arbitrary shell commands on the server.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 27 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-64wj-2chj-3r96, GHSA-93fx-5qgc-wr38

## What is CVE-2026-100857?

CVE-2026-100857 is a high-severity code injection vulnerability in AzuraCast, published on 27 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

AzuraCast before 0.23.4 contains a code injection vulnerability in the ConfigWriter::cleanUpString() method that fails to sanitize Liquidsoap string interpolation sequences, allowing authenticated users with Media or Profile permissions to inject arbitrary Liquidsoap code into station configuration. Attackers can inject #{process.run()} expressions into playlist URLs or station metadata fields that execute shell commands as the azuracast user when the station restarts.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-100857?

2 open source packages ship an affected version, including azuracast/azuracast.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `azuracast/azuracast` | Packagist | All versions | 0.23.4 |
| `azuracast/azuracast` | Packagist | All versions | 0.23.4 |

## How do I fix CVE-2026-100857?

Upgrade azuracast/azuracast to 0.23.4 or later.

## Is CVE-2026-100857 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100857 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100857 and fix it if it is affected.

What it is: CVE-2026-100857 is a high-severity code injection vulnerability in AzuraCast, published on 27 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100857 exists.

Affected packages and fixed versions:
- azuracast/azuracast (Packagist): affected all versions; fixed in 0.23.4
- azuracast/azuracast (Packagist): affected all versions; fixed in 0.23.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100857/ (Markdown: https://insights.sbomify.com/CVE-2026-100857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100857
- OSV: https://osv.dev/vulnerability/CVE-2026-100857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100857/
Summaries are generated and may contain mistakes; the official description above is the record.
