CVE-2026-100885 Krayin laravel-crm admin-config-setup API Endpoint CanInstall.php authorization

Medium 6.9 Published Updated

Attackers can bypass authorization checks in the Krayin Laravel CRM installer API, potentially gaining unauthorized access to configuration endpoints.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-100885?

CVE-2026-100885 is a medium-severity authentication bypass vulnerability in Krayin laravel-crm, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability was found in Krayin laravel-crm up to 2.2.4. This affects an unknown function of the file packages/Webkul/Installer/src/Http/Middleware/CanInstall.php of the component admin-config-setup API Endpoint. The manipulation results in authorization bypass. The attack may be launched remotely. The exploit has been made public and could be used. Upgrading to version 2.2.5 mitigates this issue. The patch is identified as 89f2916b6a46ff91bd1999ce38158fa0de8b9490. Upgrading the affected component is recommended.

Weakness: CWE-639, CWE-285

Which versions are affected by CVE-2026-100885?

How do I fix CVE-2026-100885?

No fix has been published for CVE-2026-100885 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-100885 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100885 exists.

Public exploit code: 1 Exploit-DB entry.

Sources

Also known as GHSA-6xfx-hrf7-3c42.

Is CVE-2026-100885 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free