# CVE-2026-100885: Krayin laravel-crm admin-config-setup API Endpoint CanInstall.php authorization

> Attackers can bypass authorization checks in the Krayin Laravel CRM installer API, potentially gaining unauthorized access to configuration endpoints.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-6xfx-hrf7-3c42

## What is CVE-2026-100885?

CVE-2026-100885 is a medium-severity authentication bypass vulnerability in Krayin laravel-crm, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in Krayin laravel-crm up to 2.2.4. This affects an unknown function of the file packages/Webkul/Installer/src/Http/Middleware/CanInstall.php of the component admin-config-setup API Endpoint. The manipulation results in authorization bypass. The attack may be launched remotely. The exploit has been made public and could be used. Upgrading to version 2.2.5 mitigates this issue. The patch is identified as 89f2916b6a46ff91bd1999ce38158fa0de8b9490. Upgrading the affected component is recommended.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-100885?


## How do I fix CVE-2026-100885?

No fix has been published for CVE-2026-100885 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-100885 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100885 exists.

Public exploit code:

- Krayin CRM 2.2.4 - IDOR (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100885 and fix it if it is affected.

What it is: CVE-2026-100885 is a medium-severity authentication bypass vulnerability in Krayin laravel-crm, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100885 exists.

Affected product: Krayin laravel-crm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100885/ (Markdown: https://insights.sbomify.com/CVE-2026-100885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100885
- OSV: https://osv.dev/vulnerability/CVE-2026-100885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100885/
Summaries are generated and may contain mistakes; the official description above is the record.
