# CVE-2026-100909: OctoberCMS ResizeImages.php getSourcePathForResize server-side request forgery

> Remote attackers can exploit a server-side request forgery vulnerability in OctoberCMS to access internal resources or bypass security controls.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-2xmm-m4wv-3fjh, GHSA-5528-3vrx-6443

## What is CVE-2026-100909?

CVE-2026-100909 is a medium-severity server-side request forgery vulnerability in OctoberCMS, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in OctoberCMS up to 4.1.19/4.2.25/4.3.4. The impacted element is the function getSourcePathForResize of the file modules/system/classes/ResizeImages.php. The manipulation of the argument realSourcePath results in server-side request forgery. The attack may be performed from remote. The exploit has been made public and could be used. Upgrading to version 4.3.5 and 4.4.0 is sufficient to resolve this issue. The patch is identified as 0e9736aa2c6d6bd3d60ff6ef9e0b4d32ce387f58. The affected component should be upgraded.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-100909?

2 open source packages ship an affected version, including october/october.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/october` | Packagist | From 4.3.0 | 4.3.5 |
| `october/october` | Packagist | From 4.3.0 | 4.3.5 |

## How do I fix CVE-2026-100909?

Upgrade october/october to 4.3.5 or later.

## Is CVE-2026-100909 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100909 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-100909 and fix it if it is affected.

What it is: CVE-2026-100909 is a medium-severity server-side request forgery vulnerability in OctoberCMS, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-100909 exists.

Affected packages and fixed versions:
- october/october (Packagist): affected from 4.3.0; fixed in 4.3.5
- october/october (Packagist): affected from 4.3.0; fixed in 4.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-100909/ (Markdown: https://insights.sbomify.com/CVE-2026-100909/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-100909
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-100909
- OSV: https://osv.dev/vulnerability/CVE-2026-100909

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-100909/
Summaries are generated and may contain mistakes; the official description above is the record.
