# CVE-2026-101028: Ash.count, Ash.exists and Ash.aggregate skip related resources' read policies in filters and sorts

> Attackers can bypass read policies on related resources using aggregate functions to infer hidden data existence and values.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2026
- **Updated:** 9 Oct 2026
- **Also known as:** EEF-CVE-2026-101028, GHSA-xj24-8f5c-pp5p

## What is CVE-2026-101028?

CVE-2026-101028 is a medium-severity missing authorization vulnerability in ash-project ash, published on 9 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in ash-project ash allows an actor to infer data in related records they cannot read via Ash.count/2, Ash.exists/2 and Ash.aggregate/3.

Ash.Actions.Aggregate.run/4 (lib/ash/actions/aggregate.ex) applied only the root resource's read policy before running the aggregate query. The read path also applies each related resource's read policy to filter and sort references that cross a relationship, directly (for example comments.body) or through an aggregate over one, but the aggregate path skipped that step. A caller whose filter or sort reaches these functions, for example through Ash.Query.filter_input/2, an ash_lua script, or an AshAi tool offering count or exists results, can test conditions against related rows hidden from them and recover their existence and attribute values one query at a time. Ash.read/2 and its page counts are not affected.

This issue affects ash: from 2.6.0 before 3.34.6.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-101028?

1 open source package ship an affected version, including ash.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash` | Hex | From 2.6.0 | 3.34.6 |

## How do I fix CVE-2026-101028?

Upgrade ash to 3.34.6 or later.

## Is CVE-2026-101028 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101028 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101028 and fix it if it is affected.

What it is: CVE-2026-101028 is a medium-severity missing authorization vulnerability in ash-project ash, published on 9 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101028 exists.

Affected packages and fixed versions:
- ash (Hex): affected from 2.6.0; fixed in 3.34.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101028/ (Markdown: https://insights.sbomify.com/CVE-2026-101028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101028
- OSV: https://osv.dev/vulnerability/CVE-2026-101028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101028/
Summaries are generated and may contain mistakes; the official description above is the record.
