{"answers":{"affected":"1 open source package ship an affected version, including parse.","exploited":"There is no known exploitation of CVE-2026-101042 in the wild and no public exploit code.","fix":"Upgrade parse to a fixed version for your release line: 8.6.91 or 9.10.1.","what":"CVE-2026-101042 is a high-severity authentication bypass vulnerability in parse-community parse-server, published on 27 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-101042 and fix it if it is affected.\n\nWhat it is: CVE-2026-101042 is a high-severity authentication bypass vulnerability in parse-community parse-server, published on 27 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-101042 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse (Bitnami): affected from 8.0.2; fixed in 8.6.91, 9.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-101042/ (Markdown: https://insights.sbomify.com/CVE-2026-101042/index.md)","id":"CVE-2026-101042","markdown":"https://insights.sbomify.com/CVE-2026-101042/index.md","name":"CVE-2026-101042","record":{"aliases":["BIT-parse-2026-101042","GHSA-3865-44r7-h828","GHSA-mr43-w6c2-mvjq"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Parse Server backend","requires_auth":"low_privilege","summary":"Attackers can bypass authentication checks to hijack accounts or spoof identities in Parse Server deployments using specific code-based auth adapters.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Parse Server is an open-source backend server. In versions \u003e= 9.0.0 \u003c 9.10.1-alpha.10 and \u003e= 8.0.2 \u003c 8.6.91, the code-based authentication adapters (GitHub, Google Play Games, Instagram, LINE, LinkedIn, Microsoft, QQ, Spotify, WeChat, Weibo) verify the client's authorization code with the external provider on signup and on provider linking, but not when authentication data is supplied together with a username and password on the login endpoint. As a result, a low-privileged authenticated user can attach an arbitrary, unverified provider identity to their own account without the provider ever being contacted, spoofing an external identity toward application logic that trusts the linked provider ID. An attacker can also pre-hijack accounts: by claiming the provider ID of a victim who has not yet linked that provider, the victim's later legitimate sign-in with that provider resolves to the attacker's account. Only deployments configuring one of the affected code-based auth adapters are impacted. Versions 9.10.1-alpha.10 and 8.6.91 fix the issue by running the adapter's credential verification on the login and challenge endpoints and rejecting a provider identity already linked to another user. As a workaround, disable the affected code-based auth adapters.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server 9.0.0 Authentication Bypass via Unverified Provider Identity","id":"CVE-2026-101042","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"pnpm 11.0.0 before 11.11.0 Environment Variable Exfiltration via Proxy Settings","id":"CVE-2026-101043"},"packages":[{"ecosystem":"Bitnami","fixed":["8.6.91","9.10.1"],"introduced":["8.0.2","9.0.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2026-101042"}],"prev":{"headline":"Vulnerability-Lookup - Race Condition in Account Recovery Token Consumption Allows Password Takeover","id":"CVE-2026-101041"},"products":["parse-server"],"published":"2026-09-27","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-30","vendors":["parse-community"]},"summary":"Attackers can bypass authentication checks to hijack accounts or spoof identities in Parse Server deployments using specific code-based auth adapters.","url":"https://insights.sbomify.com/CVE-2026-101042/"}