# CVE-2026-101042: Parse Server 9.0.0 Authentication Bypass via Unverified Provider Identity

> Attackers can bypass authentication checks to hijack accounts or spoof identities in Parse Server deployments using specific code-based auth adapters.

- **Severity:** High 7.4 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** BIT-parse-2026-101042, GHSA-3865-44r7-h828, GHSA-mr43-w6c2-mvjq

## What is CVE-2026-101042?

CVE-2026-101042 is a high-severity authentication bypass vulnerability in parse-community parse-server, published on 27 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Parse Server is an open-source backend server. In versions >= 9.0.0 < 9.10.1-alpha.10 and >= 8.0.2 < 8.6.91, the code-based authentication adapters (GitHub, Google Play Games, Instagram, LINE, LinkedIn, Microsoft, QQ, Spotify, WeChat, Weibo) verify the client's authorization code with the external provider on signup and on provider linking, but not when authentication data is supplied together with a username and password on the login endpoint. As a result, a low-privileged authenticated user can attach an arbitrary, unverified provider identity to their own account without the provider ever being contacted, spoofing an external identity toward application logic that trusts the linked provider ID. An attacker can also pre-hijack accounts: by claiming the provider ID of a victim who has not yet linked that provider, the victim's later legitimate sign-in with that provider resolves to the attacker's account. Only deployments configuring one of the affected code-based auth adapters are impacted. Versions 9.10.1-alpha.10 and 8.6.91 fix the issue by running the adapter's credential verification on the login and challenge endpoints and rejecting a provider identity already linked to another user. As a workaround, disable the affected code-based auth adapters.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-101042?

1 open source package ship an affected version, including parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse` | Bitnami | From 8.0.2 | 8.6.91, 9.10.1 |

## How do I fix CVE-2026-101042?

Upgrade parse to a fixed version for your release line: 8.6.91 or 9.10.1.

## Is CVE-2026-101042 being exploited?

There is no known exploitation of CVE-2026-101042 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101042 and fix it if it is affected.

What it is: CVE-2026-101042 is a high-severity authentication bypass vulnerability in parse-community parse-server, published on 27 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-101042 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse (Bitnami): affected from 8.0.2; fixed in 8.6.91, 9.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101042/ (Markdown: https://insights.sbomify.com/CVE-2026-101042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101042
- OSV: https://osv.dev/vulnerability/CVE-2026-101042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101042/
Summaries are generated and may contain mistakes; the official description above is the record.
