CVE-2026-101043 pnpm 11.0.0 before 11.11.0 Environment Variable Exfiltration via Proxy Settings
Attackers can exfiltrate environment secrets by manipulating proxy settings in a project manifest, tricking pnpm into sending sensitive data to attacker-controlled hosts.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-101043?
CVE-2026-101043 is a high-severity vulnerability in pnpm, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
pnpm versions 11.0.0 before 11.11.0 and 10.7.0 before 10.34.5 expand ${VAR} environment-variable placeholders in the httpProxy, httpsProxy, and noProxy settings read from a project's pnpm-workspace.yaml. Because the manifest is repository-controlled and the proxy keys were omitted from the request-destination key set that otherwise suppresses placeholder expansion for untrusted manifests (as already done for registry, pnprServer, registries and namedRegistries), an attacker who controls a repository's pnpm-workspace.yaml can cause a victim who clones the repository and runs a pnpm command (e.g. pnpm install) to expand environment secrets such as NPM_TOKEN or GITHUB_TOKEN into a proxy hostname or userinfo and route install traffic — and the corresponding DNS lookups — through an attacker-controlled host. The exfiltration occurs during configuration loading, before any lifecycle script executes. Fixed in pnpm 11.11.0 and 10.34.5.
Weakness: CWE-201
Which versions are affected by CVE-2026-101043?
4 open source packages ship an affected version, including pnpm.
| Package | Affected | Fixed in |
|---|---|---|
pnpm npm | From 10.7.0 | 10.34.5 |
pnpm npm | From 10.7.0 | 10.34.5 |
pnpm npm | From 11.0.0 | 11.11.0 |
pnpm npm | From 11.0.0 | 11.11.0 |
How do I fix CVE-2026-101043?
Upgrade pnpm to a fixed version for your release line: 10.34.5 or 11.11.0.
Is CVE-2026-101043 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101043 exists.
Sources
Also known as GHSA-49pq-2gf3-jw76, GHSA-vx52-2968-3vc6, MINI-m82x-vw9h-g422.