{"answers":{"affected":"4 open source packages ship an affected version, including pnpm.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101043 exists.","fix":"Upgrade pnpm to a fixed version for your release line: 10.34.5 or 11.11.0.","what":"CVE-2026-101043 is a high-severity vulnerability in pnpm, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-101043 and fix it if it is affected.\n\nWhat it is: CVE-2026-101043 is a high-severity vulnerability in pnpm, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101043 exists.\n\nAffected packages and fixed versions:\n- pnpm (npm): affected from 10.7.0; fixed in 10.34.5\n- pnpm (npm): affected from 10.7.0; fixed in 10.34.5\n- pnpm (npm): affected from 11.0.0; fixed in 11.11.0\n- pnpm (npm): affected from 11.0.0; fixed in 11.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-101043/ (Markdown: https://insights.sbomify.com/CVE-2026-101043/index.md)","id":"CVE-2026-101043","markdown":"https://insights.sbomify.com/CVE-2026-101043/index.md","name":"CVE-2026-101043","record":{"aliases":["GHSA-49pq-2gf3-jw76","GHSA-vx52-2968-3vc6","MINI-m82x-vw9h-g422"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"pnpm package manager","requires_auth":"none","summary":"Attackers can exfiltrate environment secrets by manipulating proxy settings in a project manifest, tricking pnpm into sending sensitive data to attacker-controlled hosts.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.3,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-201","name":"Insertion of Sensitive Information Into Sent Data"}],"description":"pnpm versions 11.0.0 before 11.11.0 and 10.7.0 before 10.34.5 expand ${VAR} environment-variable placeholders in the httpProxy, httpsProxy, and noProxy settings read from a project's pnpm-workspace.yaml. Because the manifest is repository-controlled and the proxy keys were omitted from the request-destination key set that otherwise suppresses placeholder expansion for untrusted manifests (as already done for registry, pnprServer, registries and namedRegistries), an attacker who controls a repository's pnpm-workspace.yaml can cause a victim who clones the repository and runs a pnpm command (e.g. pnpm install) to expand environment secrets such as NPM_TOKEN or GITHUB_TOKEN into a proxy hostname or userinfo and route install traffic — and the corresponding DNS lookups — through an attacker-controlled host. The exfiltration occurs during configuration loading, before any lifecycle script executes. Fixed in pnpm 11.11.0 and 10.34.5.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"pnpm 11.0.0 before 11.11.0 Environment Variable Exfiltration via Proxy Settings","id":"CVE-2026-101043","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"pacquet before 12.0.0-alpha.5 Path Traversal via lockfile alias","id":"CVE-2026-101044"},"packages":[{"ecosystem":"npm","fixed":["10.34.5"],"introduced":["10.7.0"],"last_affected":[],"package":"pnpm","purl":null,"source":"GHSA-vx52-2968-3vc6"},{"ecosystem":"npm","fixed":["10.34.5"],"introduced":["10.7.0"],"last_affected":[],"package":"pnpm","purl":"pkg:npm/pnpm","source":"GHSA-vx52-2968-3vc6"},{"ecosystem":"npm","fixed":["11.11.0"],"introduced":["11.0.0"],"last_affected":[],"package":"pnpm","purl":null,"source":"GHSA-vx52-2968-3vc6"},{"ecosystem":"npm","fixed":["11.11.0"],"introduced":["11.0.0"],"last_affected":[],"package":"pnpm","purl":"pkg:npm/pnpm","source":"GHSA-vx52-2968-3vc6"}],"prev":{"headline":"Parse Server 9.0.0 Authentication Bypass via Unverified Provider Identity","id":"CVE-2026-101042"},"products":["pnpm"],"published":"2026-09-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-30","vendors":["pnpm"]},"summary":"Attackers can exfiltrate environment secrets by manipulating proxy settings in a project manifest, tricking pnpm into sending sensitive data to attacker-controlled hosts.","url":"https://insights.sbomify.com/CVE-2026-101043/"}