# CVE-2026-101046: Fleet before 4.89.0 SQL Injection via ORDER BY Activity Endpoints

> An authenticated user can exploit SQL injection in Fleet activity endpoints to infer values of hidden columns via sort order manipulation.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-qhx2-24jf-9jj9, GHSA-rxhg-vcww-2mpw, GO-2026-6269

## What is CVE-2026-101046?

CVE-2026-101046 is a low-severity SQL injection vulnerability in fleetdm fleet, published on 27 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Fleet before 4.89.0 contains an SQL injection vulnerability in the activity list endpoints (GET /api/v1/fleet/activities and GET /api/v1/fleet/hosts/{id}/activities). The deprecated cursor-pagination helper appendListOptionsWithCursorToSQL interpolated the caller-supplied sort/order key into the SQL ORDER BY clause without an allowlist, so an authenticated user with read access to Activity could order results by arbitrary columns. The impact is read-only and bounded to columns on the activity_past table that are not otherwise returned in these responses (e.g. details), allowing their values to be inferred through the resulting sort order; there is no write access, privilege escalation, or reachability of node_key or other host-join columns through these endpoints. Fixed in 4.89.0, which removes the deprecated helper and passes the sort column through SanitizeColumn.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-101046?

3 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.89.0 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.89.0 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.89.0 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-101046?

Upgrade github.com/fleetdm/fleet/v4 to 4.89.0 or later.

## Is CVE-2026-101046 being exploited?

There is no known exploitation of CVE-2026-101046 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101046 and fix it if it is affected.

What it is: CVE-2026-101046 is a low-severity SQL injection vulnerability in fleetdm fleet, published on 27 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-101046 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.89.0
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.89.0
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.89.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101046/ (Markdown: https://insights.sbomify.com/CVE-2026-101046/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101046
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101046
- OSV: https://osv.dev/vulnerability/CVE-2026-101046

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101046/
Summaries are generated and may contain mistakes; the official description above is the record.
