# CVE-2026-101047: Fleet before 4.87.0 Unauthenticated iOS App Download via Predictable URLs

> Unauthenticated attackers can download in-house iOS app binaries and metadata by guessing predictable URLs on the enterprise tier.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-jqp5-cmc9-xwxg, GHSA-q9c5-pp7m-fm2g, GO-2026-6268

## What is CVE-2026-101047?

CVE-2026-101047 is a medium-severity missing authorization vulnerability in fleetdm fleet, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fleet before 4.87.0 does not protect the two endpoints that serve in-house iOS application packages and manifests (enterprise tier only) with the intended random, time-limited URL token. Because Apple's InstallEnterpriseApplication MDM command requires these URLs to be reachable without a Fleet session, they cannot rely on session-based authentication, and the missing token allows an unauthenticated attacker with network access to the Fleet server to download in-house IPA binaries and their metadata (bundle identifier, version, and name) by guessing sequential title identifiers. The impact is limited to read-only disclosure; there is no privilege escalation or write access, and the free tier is unaffected (it returns fleet.ErrMissingLicense).

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-101047?

3 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.87.0 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.87.0 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.87.0 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-101047?

Upgrade github.com/fleetdm/fleet/v4 to 4.87.0 or later.

## Is CVE-2026-101047 being exploited?

There is no known exploitation of CVE-2026-101047 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101047 and fix it if it is affected.

What it is: CVE-2026-101047 is a medium-severity missing authorization vulnerability in fleetdm fleet, published on 27 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-101047 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.87.0
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.87.0
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.87.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101047/ (Markdown: https://insights.sbomify.com/CVE-2026-101047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101047
- OSV: https://osv.dev/vulnerability/CVE-2026-101047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101047/
Summaries are generated and may contain mistakes; the official description above is the record.
