# CVE-2026-101048: Cloudreve before 4.17.0 SSRF via Admin.Read OAuth scope

> An attacker with Admin.Read scope can trigger server-side request forgery via admin node test endpoints, allowing internal network probing and data exfiltration.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-pg9h-w4pm-q3vr, GHSA-v6w6-358x-2433, GO-2026-6106

## What is CVE-2026-101048?

CVE-2026-101048 is a medium-severity server-side request forgery vulnerability in cloudreve, published on 27 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cloudreve before 4.17.0 registers the administrative node test endpoints (POST /api/v4/admin/node/test and POST /api/v4/admin/node/test/downloader) without requiring the Admin.Write OAuth scope, unlike the node create/update/delete routes. An OAuth client that has been authorized by an administrator with only the Admin.Read scope can therefore submit attacker-controlled node definitions and cause the Cloudreve server to issue outbound requests to arbitrary URLs, enabling blind server-side request forgery, internal service probing, and delivery of signed Cloudreve slave-style requests to attacker-chosen endpoints.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-101048?

7 open source packages ship an affected version, including github.com/cloudreve/Cloudreve/v3, github.com/cloudreve/Cloudreve and github.com/cloudreve/Cloudreve/v4.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions to 3.0.0-20250225100611-da4e44b77af4 | None |
| `github.com/cloudreve/Cloudreve/v3` | Go | All versions to 3.0.0-20250225100611-da4e44b77af4 | None |
| `github.com/cloudreve/Cloudreve` | Go | All versions | None |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260626022735-332a9d800205 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260626022735-332a9d800205 |
| `github.com/cloudreve/Cloudreve/v4` | Go | All versions | 4.0.0-20260626022735-332a9d800205 |

## How do I fix CVE-2026-101048?

Upgrade to a fixed version.

## Is CVE-2026-101048 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101048 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101048 and fix it if it is affected.

What it is: CVE-2026-101048 is a medium-severity server-side request forgery vulnerability in cloudreve, published on 27 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101048 exists.

Affected packages and fixed versions:
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions up to 3.0.0-20250225100611-da4e44b77af4; no fix listed
- github.com/cloudreve/Cloudreve/v3 (Go): affected all versions up to 3.0.0-20250225100611-da4e44b77af4; no fix listed
- github.com/cloudreve/Cloudreve (Go): affected all versions; no fix listed
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260626022735-332a9d800205
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260626022735-332a9d800205
- github.com/cloudreve/Cloudreve/v4 (Go): affected all versions; fixed in 4.0.0-20260626022735-332a9d800205

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101048/ (Markdown: https://insights.sbomify.com/CVE-2026-101048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101048
- OSV: https://osv.dev/vulnerability/CVE-2026-101048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101048/
Summaries are generated and may contain mistakes; the official description above is the record.
