# CVE-2026-101064: Obot before v0.23.0 Server-Side Request Forgery via MCP

> Privileged users can exploit SSRF in Obot to access internal services and cloud metadata, disclosing sensitive credentials.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-jgh3-fggc-mcpm, GHSA-jvrr-x58p-75mm, GO-2026-6522

## What is CVE-2026-101064?

CVE-2026-101064 is a high-severity server-side request forgery vulnerability in obot-platform obot, published on 27 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Obot before v0.23.0 contains a server-side request forgery vulnerability in remote MCP server registration that allows privileged users to specify arbitrary URLs without destination validation. Attackers with Power User or higher roles can coerce Obot to make requests to internal services and cloud metadata endpoints, reading responses in error messages to disclose sensitive credentials.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-101064?

3 open source packages ship an affected version, including github.com/obot-platform/obot.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/obot-platform/obot` | Go | All versions | 0.23.0 |
| `github.com/obot-platform/obot` | Go | All versions | 0.23.0 |
| `github.com/obot-platform/obot` | Go | All versions | 0.23.0 |

## How do I fix CVE-2026-101064?

Upgrade github.com/obot-platform/obot to 0.23.0 or later.

## Is CVE-2026-101064 being exploited?

There is no known exploitation of CVE-2026-101064 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101064 and fix it if it is affected.

What it is: CVE-2026-101064 is a high-severity server-side request forgery vulnerability in obot-platform obot, published on 27 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-101064 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/obot-platform/obot (Go): affected all versions; fixed in 0.23.0
- github.com/obot-platform/obot (Go): affected all versions; fixed in 0.23.0
- github.com/obot-platform/obot (Go): affected all versions; fixed in 0.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101064/ (Markdown: https://insights.sbomify.com/CVE-2026-101064/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101064
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101064
- OSV: https://osv.dev/vulnerability/CVE-2026-101064

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101064/
Summaries are generated and may contain mistakes; the official description above is the record.
