# CVE-2026-10108: xiaomusic 0.5.7 Path Traversal via GET /music endpoint

> Unauthenticated attackers can read arbitrary files outside the intended directory via path traversal in the GET /music endpoint.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-5j8p-5rrj-8wjg, PYSEC-2026-3429

## What is CVE-2026-10108?

CVE-2026-10108 is a high-severity path traversal vulnerability in hanxi xiaomusic, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

xiaomusic v0.5.7 contains an unauthenticated path traversal vulnerability in the GET /music/{file_path:path} endpoint that allows unauthenticated attackers to read arbitrary files outside the intended music directory by exploiting an incomplete path prefix check. Attackers can request files from sibling directories whose names share the music_path prefix by crafting traversal sequences, bypassing the path restriction due to the missing trailing separator in the comparison logic to retrieve arbitrary files from the server.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-10108?

3 open source packages ship an affected version, including xiaomusic.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `xiaomusic` | PyPI | All versions | 0.5.8 |
| `xiaomusic` | PyPI | All versions | 0.5.8 |
| `xiaomusic` | PyPI | All versions | 0.5.8 |

## How do I fix CVE-2026-10108?

Upgrade xiaomusic to 0.5.8 or later.

## Is CVE-2026-10108 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10108 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10108 and fix it if it is affected.

What it is: CVE-2026-10108 is a high-severity path traversal vulnerability in hanxi xiaomusic, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-10108 exists.

Affected packages and fixed versions:
- xiaomusic (PyPI): affected all versions; fixed in 0.5.8
- xiaomusic (PyPI): affected all versions; fixed in 0.5.8
- xiaomusic (PyPI): affected all versions; fixed in 0.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10108/ (Markdown: https://insights.sbomify.com/CVE-2026-10108/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10108
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10108
- OSV: https://osv.dev/vulnerability/CVE-2026-10108

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10108/
Summaries are generated and may contain mistakes; the official description above is the record.
