# CVE-2026-101087: Nezha 2.0.10 through 2.3.2 SSRF Denylist Bypass IPv6

> Authenticated users can bypass SSRF denylists via IPv6 transition ranges to access restricted internal endpoints in Nezha.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 27 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-jr2j-7hvh-h4q9, GHSA-qvpf-fj3j-7cw6

## What is CVE-2026-101087?

CVE-2026-101087 is a medium-severity server-side request forgery vulnerability in nezhahq nezha, published on 27 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Nezha versions 2.0.10 through 2.3.2 use a restricted HTTP client to validate user-configurable notification and DDNS webhook URLs, but the denylist did not cover IPv6 transition ranges — specifically the 6to4 prefix 2002::/16 and the local-use IPv4/IPv6 translation prefix 64:ff9b:1::/48. Because such addresses satisfy Go's netip.Addr.IsGlobalUnicast check, the URL validator accepted them. An authenticated user able to configure a webhook may be able to cause the dashboard to issue requests to an otherwise restricted IPv6 endpoint, but only where the dashboard's network provides unusual or non-standards-compliant routing for these transition ranges; no direct path to an IPv4 metadata, loopback, or private-network HTTP request has been demonstrated. The issue is fixed in version 2.3.3 (commit d1fcde8e), which blocks both prefixes.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-101087?


## How do I fix CVE-2026-101087?

No fix has been published for CVE-2026-101087 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-101087 being exploited?

There is no known exploitation of CVE-2026-101087 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101087 and fix it if it is affected.

What it is: CVE-2026-101087 is a medium-severity server-side request forgery vulnerability in nezhahq nezha, published on 27 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-101087 in the wild and no public exploit code.

Affected product: nezhahq nezha. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101087/ (Markdown: https://insights.sbomify.com/CVE-2026-101087/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101087
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101087
- OSV: https://osv.dev/vulnerability/CVE-2026-101087

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101087/
Summaries are generated and may contain mistakes; the official description above is the record.
