# CVE-2026-10142: kafka-python prior to 2.3.2 Denial of Service via Protocol Parser Frame Length

> A malicious broker or MITM attacker can cause memory exhaustion or connection hangs in kafka-python by sending crafted frame lengths.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-10142, GHSA-m3px-q5gj-j9x7, PYSEC-2026-2190, UBUNTU-CVE-2026-10142, openSUSE-SU-2026:11004-1

## What is CVE-2026-10142?

CVE-2026-10142 is a high-severity denial of service vulnerability in Dana Powers kafka-python, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

kafka-python prior to 2.3.2 contains a denial-of-service vulnerability in the protocol parser that allows a malicious broker or machine-in-the-middle attacker to exhaust memory or hang connections by sending a crafted 4-byte frame length value without bounds validation. Attackers can send a specially crafted frame length through the receive_bytes() function to trigger either a multi-gigabyte memory allocation or an uncaught ValueError that leaves the connection in a broken state, causing requests to hang and consumers to stop heartbeating until restart.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-10142?

3 open source packages ship an affected version, including kafka-python. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kafka-python` | PyPI | All versions | 2.3.2 |
| `kafka-python` | PyPI | All versions | 2.3.2 |
| `kafka-python` | PyPI | All versions | 2.3.2 |
| `python-kafka-python` | openSUSE:Tumbleweed | All versions | 2.3.2-1.1 |

Products: Dpkp Kafka-Python.

## How do I fix CVE-2026-10142?

Upgrade kafka-python to 2.3.2 or later.

## Is CVE-2026-10142 being exploited?

There is no known exploitation of CVE-2026-10142 in the wild and no public exploit code.

## Other vulnerabilities in Dana Powers kafka-python

- [CVE-2026-10143](https://insights.sbomify.com/CVE-2026-10143/): kafka-python prior to 2.3.2 DoS via SCRAM Iteration Count in scram.py (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-10142 and fix it if it is affected.

What it is: CVE-2026-10142 is a high-severity denial of service vulnerability in Dana Powers kafka-python, published on 10 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-10142 in the wild and no public exploit code.

Affected packages and fixed versions:
- kafka-python (PyPI): affected all versions; fixed in 2.3.2
- kafka-python (PyPI): affected all versions; fixed in 2.3.2
- kafka-python (PyPI): affected all versions; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-10142/ (Markdown: https://insights.sbomify.com/CVE-2026-10142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-10142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-10142
- OSV: https://osv.dev/vulnerability/CVE-2026-10142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-10142/
Summaries are generated and may contain mistakes; the official description above is the record.
