CVE-2026-10148 Cross-site scripting in Booking for Appointments and Events Calendar – Amelia

Medium 6.4 Published Updated

Authenticated attackers with Contributor access can inject arbitrary scripts via the load_manually parameter in Amelia plugin, leading to stored XSS.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-10148?

CVE-2026-10148 is a medium-severity cross-site scripting vulnerability in melograno Booking for Appointments and Events Calendar – Amelia, published on 12 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The Booking for Appointments and Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple Elementor widgets in versions up to and including 2.4.9. This is due to insufficient input sanitization and output escaping on the 'load_manually' parameter in the render() methods of classes. This makes it possible for authenticated attackers, with Contributor-level access and above who can use Elementor, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.4.8.

Weakness: CWE-79

Which versions are affected by CVE-2026-10148?

How do I fix CVE-2026-10148?

No fix has been published for CVE-2026-10148 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-10148 being exploited?

There is no known exploitation of CVE-2026-10148 in the wild and no public exploit code.

Sources

Also known as GHSA-h5pf-gc8w-pff5.

Is CVE-2026-10148 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free