# CVE-2026-101894: @xhmikosr/decompress: Path traversal via symlink chain

> Attackers can exploit symlink chains in archives to read or write files outside the target directory, potentially leading to remote code execution.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** GHSA-hrh2-vp3x-79xf, MINI-f8wr-25hq-6mhp, MINI-p372-5wx7-jwvr, MINI-xrrc-fcjx-mq7g, ROOT-APP-NPM-CVE-2026-101894

## What is CVE-2026-101894?

CVE-2026-101894 is a critical path traversal vulnerability in XhmikosR decompress, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The decompress package for Node.js extracts archives. Prior to 10.2.2 and 11.1.4, the default decompress(input, output) API relies on lexical containment checks that do not account for the kernel following a planted symlink chain. An attacker can supply a crafted archive containing chained symlink entries so that a later entry resolves outside the output directory. This allows files outside output to be read or written, and overwriting startup scripts or configuration can lead to remote code execution. The maintained @xhmikosr/decompress package is fixed in 10.2.2 and 11.1.4, but the separately affected unmaintained decompress package remains unpatched through 4.2.1. This vulnerability results from a bypass of the incomplete hardening for CVE-2026-53486. @xhmikosr/decompress is fixed in versions 10.2.2 and 11.1.4.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-101894?

6 open source packages ship an affected version, including @xhmikosr/decompress and decompress.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xhmikosr/decompress` | npm | All versions | 10.2.2 |
| `@xhmikosr/decompress` | npm | All versions | 10.2.2 |
| `@xhmikosr/decompress` | npm | From 11.0.0 | 11.1.4 |
| `@xhmikosr/decompress` | npm | From 11.0.0 | 11.1.4 |
| `decompress` | npm | All versions to 4.2.1 | None |
| `decompress` | npm | All versions to 4.2.1 | None |

## How do I fix CVE-2026-101894?

Upgrade @xhmikosr/decompress to a fixed version for your release line: 10.2.2 or 11.1.4.

## Is CVE-2026-101894 being exploited?

There is no known exploitation of CVE-2026-101894 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-101894 PoC: @xhmikosr/decompress symlink-chain archive path traversal (bypass CVE-2026-53486). Node lab + lockfile scan + mass evil.tar upload exploit. CVSS 9.1. https://pocbit.org/pocs/cve-2026-101894 (github_poc): https://github.com/murrez/CVE-2026-101894

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101894 and fix it if it is affected.

What it is: CVE-2026-101894 is a critical path traversal vulnerability in XhmikosR decompress, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-101894 in the wild and no public exploit code.

Affected packages and fixed versions:
- @xhmikosr/decompress (npm): affected all versions; fixed in 10.2.2
- @xhmikosr/decompress (npm): affected all versions; fixed in 10.2.2
- @xhmikosr/decompress (npm): affected from 11.0.0; fixed in 11.1.4
- @xhmikosr/decompress (npm): affected from 11.0.0; fixed in 11.1.4
- decompress (npm): affected all versions up to 4.2.1; no fix listed
- decompress (npm): affected all versions up to 4.2.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101894/ (Markdown: https://insights.sbomify.com/CVE-2026-101894/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101894
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101894
- OSV: https://osv.dev/vulnerability/CVE-2026-101894

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101894/
Summaries are generated and may contain mistakes; the official description above is the record.
