CVE-2026-101896 Angular: Denial of Service via Numeric URL Matrix Parameters in Server-Side Rendering (SSR)

High 8.2 Published Updated

An attacker can exhaust server memory via crafted URL matrix parameters in Angular SSR, causing denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-101896?

CVE-2026-101896 is a high-severity denial of service vulnerability in @angular angular, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.32, 21.2.24, and 22.2.0, the @angular/router URL parser stores numeric matrix parameter names and numeric outlet names as properties on initially empty JavaScript objects during Node.js server-side rendering. V8 can interpret these URL-derived keys as array indices and allocate dense backing stores sized to high numeric values, so repeated small path segments cause disproportionate per-segment heap consumption. An unauthenticated attacker can send overlapping requests containing repeated numeric matrix parameters when SSR is enabled, the router directly parses the request URL, and upstream proxies allow semicolons and multiple path segments, eventually exhausting the Node.js old-space heap and terminating the SSR worker. Pure client-side Angular applications are not affected. This issue is fixed in versions 20.3.32, 21.2.24, and 22.2.0.

Weakness: CWE-770, CWE-400

Which versions are affected by CVE-2026-101896?

8 open source packages ship an affected version, including @angular/router.

PackageAffectedFixed in
@angular/router npmAll versions to 19.2.25None
@angular/router npmAll versions to 19.2.25None
@angular/router npmFrom 20.0.020.3.32
@angular/router npmFrom 20.0.020.3.32
@angular/router npmFrom 21.0.021.2.24
@angular/router npmFrom 21.0.021.2.24
2 more packages
@angular/router npmFrom 22.0.022.2.0
@angular/router npmFrom 22.0.022.2.0

How do I fix CVE-2026-101896?

Upgrade @angular/router to a fixed version for your release line: 20.3.32, 21.2.24 or 22.2.0.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-101896 being exploited?

There is no known exploitation of CVE-2026-101896 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-101896, GHSA-ff3f-86qr-9cv3.

Is CVE-2026-101896 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free