# CVE-2026-101896: Angular: Denial of Service via Numeric URL Matrix Parameters in Server-Side Rendering (SSR)

> An attacker can exhaust server memory via crafted URL matrix parameters in Angular SSR, causing denial of service.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 20 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-101896, GHSA-ff3f-86qr-9cv3

## What is CVE-2026-101896?

CVE-2026-101896 is a high-severity denial of service vulnerability in @angular angular, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.32, 21.2.24, and 22.2.0, the @angular/router URL parser stores numeric matrix parameter names and numeric outlet names as properties on initially empty JavaScript objects during Node.js server-side rendering. V8 can interpret these URL-derived keys as array indices and allocate dense backing stores sized to high numeric values, so repeated small path segments cause disproportionate per-segment heap consumption. An unauthenticated attacker can send overlapping requests containing repeated numeric matrix parameters when SSR is enabled, the router directly parses the request URL, and upstream proxies allow semicolons and multiple path segments, eventually exhausting the Node.js old-space heap and terminating the SSR worker. Pure client-side Angular applications are not affected. This issue is fixed in versions 20.3.32, 21.2.24, and 22.2.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-101896?

8 open source packages ship an affected version, including @angular/router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@angular/router` | npm | All versions to 19.2.25 | None |
| `@angular/router` | npm | All versions to 19.2.25 | None |
| `@angular/router` | npm | From 20.0.0 | 20.3.32 |
| `@angular/router` | npm | From 20.0.0 | 20.3.32 |
| `@angular/router` | npm | From 21.0.0 | 21.2.24 |
| `@angular/router` | npm | From 21.0.0 | 21.2.24 |
| `@angular/router` | npm | From 22.0.0 | 22.2.0 |
| `@angular/router` | npm | From 22.0.0 | 22.2.0 |

## How do I fix CVE-2026-101896?

Upgrade @angular/router to a fixed version for your release line: 20.3.32, 21.2.24 or 22.2.0.

## Is CVE-2026-101896 being exploited?

There is no known exploitation of CVE-2026-101896 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101896 and fix it if it is affected.

What it is: CVE-2026-101896 is a high-severity denial of service vulnerability in @angular angular, published on 14 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-101896 in the wild and no public exploit code.

Affected packages and fixed versions:
- @angular/router (npm): affected all versions up to 19.2.25; no fix listed
- @angular/router (npm): affected all versions up to 19.2.25; no fix listed
- @angular/router (npm): affected from 20.0.0; fixed in 20.3.32
- @angular/router (npm): affected from 20.0.0; fixed in 20.3.32
- @angular/router (npm): affected from 21.0.0; fixed in 21.2.24
- @angular/router (npm): affected from 21.0.0; fixed in 21.2.24
- @angular/router (npm): affected from 22.0.0; fixed in 22.2.0
- @angular/router (npm): affected from 22.0.0; fixed in 22.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101896/ (Markdown: https://insights.sbomify.com/CVE-2026-101896/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101896
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101896
- OSV: https://osv.dev/vulnerability/CVE-2026-101896

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101896/
Summaries are generated and may contain mistakes; the official description above is the record.
