# CVE-2026-101898: Axios: HTTP/2 adapter bypasses configured DNS lookup and proxy controls

> Attackers can bypass configured proxy and DNS lookup policies in Axios HTTP/2 requests, potentially accessing internal resources or evading network controls.

- **Severity:** High 7.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** CLEANSTART-2026-TR55390, CLEANSTART-2026-XT17463, CLEANSTART-2026-YE85588, CLSA-2026-1791798720, CLSA-2026-1791814903, DEBIAN-CVE-2026-101898, ECHO-3c13-f6ab-bd21, GHSA-3pq3-5fj3-cg6v, MINI-2x8h-rgww-5xrg, MINI-3wrm-4fpr-2c4p, MINI-6vhx-hxh7-76m4, MINI-74vw-c739-rc62, MINI-8c94-96xm-6483, MINI-9rf4-fmp7-82m4, MINI-chj7-p73r-4qch, MINI-g2q5-ghqc-6xc7, MINI-m64r-5xc2-frfq, MINI-vmqq-386x-292c, MINI-vq4g-f7fg-g3r3, MINI-wqc6-7wm9-2wgr, ROOT-APP-NPM-CVE-2026-101898, UBUNTU-CVE-2026-101898

## What is CVE-2026-101898?

CVE-2026-101898 is a high-severity server-side request forgery vulnerability in axios, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Axios is a promise-based HTTP client for the browser and Node.js. From 1.13.0 until 1.20.0, Axios HTTP/2 request setup does not consistently apply proxy settings and caller-supplied DNS lookup policy. An HTTPS request uses httpVersion: 2 with explicit config.proxy or environment-derived proxy settings, or relies on caller-supplied config.lookup DNS policy. The HTTP/2 path can connect without the configured proxy behavior or without applying the caller-supplied config.lookup policy before http2.connect(). Requests can bypass the intended proxy route or the caller-supplied DNS resolution policy. This issue is fixed in version 1.20.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-101898?

2 open source packages ship an affected version, including axios.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 1.13.0 | 1.20.0 |
| `axios` | npm | From 1.13.0 | 1.20.0 |

## How do I fix CVE-2026-101898?

Upgrade axios to 1.20.0 or later.

## Is CVE-2026-101898 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101898 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101898 and fix it if it is affected.

What it is: CVE-2026-101898 is a high-severity server-side request forgery vulnerability in axios, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101898 exists.

Affected packages and fixed versions:
- axios (npm): affected from 1.13.0; fixed in 1.20.0
- axios (npm): affected from 1.13.0; fixed in 1.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101898/ (Markdown: https://insights.sbomify.com/CVE-2026-101898/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101898
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101898
- OSV: https://osv.dev/vulnerability/CVE-2026-101898

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101898/
Summaries are generated and may contain mistakes; the official description above is the record.
