CVE-2026-101901 Axios: Denial of Service via Unhandled 'error' Event in HTTP/2 ClientHttp2Session Initialization

High 8.2 Published Updated

An attacker can cause a Node.js process crash via unhandled errors in Axios HTTP/2 sessions, requiring HTTP/2 usage.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-101901?

CVE-2026-101901 is a high-severity denial of service vulnerability in axios, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Axios is a promise-based HTTP client for the browser and Node.js. From 1.13.0 until 1.20.0, Http2Sessions does not install adequate error handling for a ClientHttp2Session during Axios HTTP/2 session initialization or reuse. A request uses httpVersion: 2 and the ClientHttp2Session emits an error during session initialization or reuse. The unhandled session error escapes normal Promise rejection handling. The uncaught error can terminate the Node.js process and cause denial of service. This issue is fixed in version 1.20.0.

Weakness: CWE-400

Which versions are affected by CVE-2026-101901?

2 open source packages ship an affected version, including axios.

PackageAffectedFixed in
axios npmFrom 1.13.01.20.0
axios npmFrom 1.13.01.20.0

How do I fix CVE-2026-101901?

Upgrade axios to 1.20.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-101901 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101901 exists.

Sources

Also known as CLEANSTART-2026-FG90857, CLEANSTART-2026-HY63925, CLEANSTART-2026-TE72619, DEBIAN-CVE-2026-101901, ECHO-ee9d-b763-761c, GHSA-542g-h47m-68v8 and 14 more.

Is CVE-2026-101901 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free