# CVE-2026-101908: Axios: Prototype pollution gadget in fetch adapter can alter outbound requests


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** CLEANSTART-2026-EI20913, CLEANSTART-2026-MZ38704, CLEANSTART-2026-VK76913, CLEANSTART-2026-ZN41930, DEBIAN-CVE-2026-101908, ECHO-3007-50ef-28a9, GHSA-vh66-26gq-q6x8, MINI-2r4f-pp9j-48m6, MINI-3348-5gmh-pr4h, MINI-4c3r-q59q-m2j2, MINI-5p9g-h4m5-4vrf, MINI-7c2h-fg2q-ff2v, MINI-89xv-287m-jrfg, MINI-c8cv-2xq5-jvw8, MINI-fhgc-q3pf-68jc, MINI-gx98-j7mq-f69f, MINI-hpvh-23vg-mw8h, MINI-jmc3-3mh3-7jpf, MINI-p676-584f-8mjv, MINI-phjv-427h-qh62, MINI-q9x3-8hwr-x3h8, MINI-r3r9-6r4m-q88g, MINI-x8rc-qq2f-hgxf, MINI-xh5m-xx3w-g875, MINI-xj3m-p7v8-394r, UBUNTU-CVE-2026-101908

## What is CVE-2026-101908?

CVE-2026-101908 is a medium-severity vulnerability in axios, published on 28 Sep 2026. 

### Official description

Axios is a promise-based HTTP client for the browser and Node.js. From 1.7.0 until 1.20.0, the fetch adapter constructs a Request with sanitized resolvedOptions but then calls fetch with the original fetchOptions. A separate same-process prototype-pollution flaw populates Object.prototype.headers so fetchOptions.headers resolves through inheritance. The inherited fetchOptions.headers value overrides the sanitized Request headers through the second argument to fetch after Request construction. Attacker-controlled request headers can alter authorization, caching, metadata-service access, or application-specific behavior. This issue is fixed in version 1.20.0.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-101908?

2 open source packages ship an affected version, including axios.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `axios` | npm | From 1.7.0 | 1.20.0 |
| `axios` | npm | From 1.7.0 | 1.20.0 |

## How do I fix CVE-2026-101908?

Upgrade axios to 1.20.0 or later.

## Is CVE-2026-101908 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101908 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101908 and fix it if it is affected.

What it is: CVE-2026-101908 is a medium-severity vulnerability in axios, published on 28 Sep 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101908 exists.

Affected packages and fixed versions:
- axios (npm): affected from 1.7.0; fixed in 1.20.0
- axios (npm): affected from 1.7.0; fixed in 1.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101908/ (Markdown: https://insights.sbomify.com/CVE-2026-101908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101908
- OSV: https://osv.dev/vulnerability/CVE-2026-101908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101908/
Summaries are generated and may contain mistakes; the official description above is the record.
