# CVE-2026-101911: ip-address: Address6 builds a parse diagnostic proportional to the input with no length bound, allowing a single long string to stall or crash the process

> Attackers can cause denial of service by passing extremely long strings to the Address6 parser, leading to process stalls or crashes.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 1 Oct 2026
- **Also known as:** CLEANSTART-2026-FL62325, CLEANSTART-2026-FP38889, CLEANSTART-2026-TU72470, CLEANSTART-2026-WB16925, CLSA-2026-1790862953, CLSA-2026-1790937671, CLSA-2026-1791028139, DEBIAN-CVE-2026-101911, ECHO-0295-6e78-716e, GHSA-h3mg-xc3c-68pw, MINI-22wq-qx3p-j7jf, MINI-24mp-7j7c-869j, MINI-3q9c-8hwh-2rq7, MINI-44fq-jjqh-9q7j, MINI-4794-35qc-4c2j, MINI-4cf8-cp2h-fpmf, MINI-7cwq-76cc-6rf7, MINI-7mw9-997g-mx26, MINI-8f98-q668-29rf, MINI-8p62-v29m-5g43, MINI-cx7m-33h4-2844, MINI-f726-6hg4-vfqc, MINI-fhmp-258q-qg87, MINI-gqcc-p46c-mv72, MINI-gv2c-9377-wvmh, MINI-h6qf-74rp-vrpm, MINI-h8vq-hg3g-4jcm, MINI-j7c9-mjp2-847w, MINI-jcmp-v2hv-9mcj, MINI-jvqw-w5wr-m6qr, MINI-mjpw-85wf-8x9g, MINI-mrvw-27v9-4gwc, MINI-pq92-gv2w-36jh, MINI-qcvr-cxfw-q43r, MINI-qrj7-8r77-23qw, MINI-vmf6-pq6w-8353, MINI-w72w-cphv-3hvq, MINI-wp9j-hcmr-2c98, MINI-x2w7-hc36-456p, MINI-x3g5-w36w-84w6, MINI-xhc8-g587-3hr5, MINI-xr2m-4774-7p89, UBUNTU-CVE-2026-101911

## What is CVE-2026-101911?

CVE-2026-101911 is a medium-severity denial of service vulnerability in beaugunderson ip-address, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ip-address is a library for parsing and manipulating IPv4 and IPv6 addresses in JavaScript. Prior to 10.7.1, the Address6 constructor, Address6.isValid, and parse code in src/ipv6.ts accept unbounded strings and expand invalid characters through RE_BAD_CHARACTERS into large diagnostics. Material impact occurs only when an application accepts a very large attacker-controlled field and passes it to Address6 parsing without an earlier length bound. Common URL and header limits, and common body-parser defaults, generally constrain the effect; common defaults typically exclude 32 MiB fields. Megabyte-scale fields can cause a synchronous stall and high transient memory use, approximately 16 MiB can trigger an invalid string length exception, and process termination occurs at approximately 32 MiB. The affected entry points include Address6.isValid and construction paths that reach parse. This issue is fixed in version 10.7.1.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-101911?

2 open source packages ship an affected version, including ip-address.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ip-address` | npm | All versions | 10.7.1 |
| `ip-address` | npm | All versions | 10.7.1 |

## How do I fix CVE-2026-101911?

Upgrade ip-address to 10.7.1 or later.

## Is CVE-2026-101911 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101911 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101911 and fix it if it is affected.

What it is: CVE-2026-101911 is a medium-severity denial of service vulnerability in beaugunderson ip-address, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-101911 exists.

Affected packages and fixed versions:
- ip-address (npm): affected all versions; fixed in 10.7.1
- ip-address (npm): affected all versions; fixed in 10.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101911/ (Markdown: https://insights.sbomify.com/CVE-2026-101911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101911
- OSV: https://osv.dev/vulnerability/CVE-2026-101911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101911/
Summaries are generated and may contain mistakes; the official description above is the record.
