# CVE-2026-101914: @grpc/grpc-js: The exact path match matcher incorrectly only applies a prefix match for case-insensitive matches

> Attackers can bypass RBAC restrictions in @grpc/grpc-js by exploiting a prefix matching flaw in case-insensitive path matching, gaining unauthorized access to protected methods.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** GHSA-88h9-xgvx-hvf2

## What is CVE-2026-101914?

CVE-2026-101914 is a medium-severity missing authorization vulnerability in grpc-node, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@grpc/grpc-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.13.1 and 1.14.1, the exact path (method name) matcher used by RBAC performs a prefix comparison instead of an equality comparison when case-insensitive matching is enabled. If one service method name prefixes another and the methods have different access rules, a request for the longer method can match the shorter method's rule and cause incorrect authorization. This issue is fixed in versions 1.13.1 and 1.14.1.

Weakness: CWE-863 (Incorrect Authorization), CWE-187 (Partial String Comparison)

## Which versions are affected by CVE-2026-101914?

4 open source packages ship an affected version, including @grpc/grpc-js-xds.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@grpc/grpc-js-xds` | npm | All versions | 1.13.1 |
| `@grpc/grpc-js-xds` | npm | All versions | 1.13.1 |
| `@grpc/grpc-js-xds` | npm | From 1.14.0 | 1.14.1 |
| `@grpc/grpc-js-xds` | npm | From 1.14.0 | 1.14.1 |

## How do I fix CVE-2026-101914?

Upgrade @grpc/grpc-js-xds to a fixed version for your release line: 1.13.1 or 1.14.1.

## Is CVE-2026-101914 being exploited?

There is no known exploitation of CVE-2026-101914 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-101914 and fix it if it is affected.

What it is: CVE-2026-101914 is a medium-severity missing authorization vulnerability in grpc-node, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-101914 in the wild and no public exploit code.

Affected packages and fixed versions:
- @grpc/grpc-js-xds (npm): affected all versions; fixed in 1.13.1
- @grpc/grpc-js-xds (npm): affected all versions; fixed in 1.13.1
- @grpc/grpc-js-xds (npm): affected from 1.14.0; fixed in 1.14.1
- @grpc/grpc-js-xds (npm): affected from 1.14.0; fixed in 1.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-101914/ (Markdown: https://insights.sbomify.com/CVE-2026-101914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-101914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-101914
- OSV: https://osv.dev/vulnerability/CVE-2026-101914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-101914/
Summaries are generated and may contain mistakes; the official description above is the record.
